0

I have a phone that is not being synched with the server despite the following attempts of troubleshooting:

  1. Telephone has data and credit
  2. Data is on and airplane mode is off
  3. Phone was restarted 3 times already
  4. commCare has 376 pending forms.
  5. Wi-Fi was tried and it also failed.

I don't want to use clear user data as all forms will be lost.

Any idea what could be happening and what other option I have to fix it?

1
  • Hi @JuanRomeroGonzalez I think this question is better suited for our support team. Would you mind directing this query to support at dimagi dot com? Feb 21 '17 at 15:55
1

Posting this here just in case anyone else experiences the problem. We recently experienced this issue with another project and followed the steps below to debug the problem

On the mobile device:

  • We went to saved forms on the user's device and then filtered by unsent forms only.

  • The user had about 187 unsent forms, scrolled to the bottom of the unsent forms list, and tried to open the last form. We got an error saying: "Unable to open encrypted form..."

  • We then long pressed this form and then selected Scan Record Integrity. We got an error as well.

  • We then tried to sync again after doing this, and it still failed.

  • Next, we deleted this record, and the device started to sync.

  • It stopped syncing after a while, and going back to the list, we found another form with the same error. We deleted that and the sync completed.

Sometimes, the unsent forms may get corrupt / deleted and this blocks the sync from completing.

0

Are you able to access www.commcarehq.org from the phone's browser? If you can't, there might be a connection issue on the device (it can't connect to CommCareHQ). I would also check your phone's date and time to make sure its correct.

If you can access www.commcarehq.org from your phone's browser and the date and time are correct, you can report an issue to our support team.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.