3

This is driving me more than a little insane.

Anything my wife backs up to Google Photos is neatly sorted and categorized into subfolders by year in her linked Google Drive. It's been this way for a few years now.

Mine doesn't do this; it's all just a clusterfudge of everything.

I've very recently set her mother's account to back up photos to Google Photos and, in turn, Drive. Hers, too, sorts them to automatically-generated subfolders by year.

Why is it doing this for them? How do I get it do behave this way for me? I've revisited this issue off and on for more than a year with my wife's account, and now, with her mother's brand-new account, to see it behaving as I've always wanted mine to, I'm at my wit's end.

Does anyone have any insights regarding this?

  • 1
    Are you backing up your photos from a smartphone? – ale Apr 3 '17 at 18:45
  • Sometimes, but also from my PC or laptop. The only solution I found was to start a new account and upload them through there, after which they were automatically sorted for me. – Eiketsu May 2 '17 at 19:55
2

Hey you need to enable "Automatically put Google photos into a folder in 'My drive'". Option in your Google drive settings.

Open Google Drive in app or website > settings > Google photos (section) > turn on "Automatically put Google photos into a folder in 'My drive'". Option.

Give it a day to update.

If haven't worked then then try uninstalling and reinstalling Google photos application in your smartphone.

Google Drive for android application settings

  • I've had that on my original account for a while now, and tried toggling it on and off through the past few months, with no discernible difference. I just migrated everything to another account. That seems to be the only real 'fix'. – Eiketsu Apr 3 '17 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.