Most of my post titles on my blog use foreign language text which requires Unicode to show up correctly. When I post with a foreign language title all the Unicode characters are completely deleted from the permalink and I'm left with something generic like "post-6.html". What can I do? I'm using Blogger in the United States.

2 Answers 2


From Blogger Post Editor, you can customize your posts with custom permalinks setting. If you prefer to use a custom permalink, you can do so via the “Permalink” option in the Post Settings box.

example www.nameofblog.blogspot.com/2012/06/post-6.html .

Add custom permalink path on Blogger

The bolded area is the portion of the URL that is customizable.

If the custom permalink you entered already exists, Blogger will attempt find a free one for you.

At present, the characters allowed in a custom URL are limited to: a-z, A-Z, 0-1. The only special characters available are underscore, dash, and period.

You can read here for more details about it.


I do not believe there is any way to make Blogger do this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.