3

I have a personal Gmail account (i.e [email protected]). I also have a second email account provided to me by my organisation, (i.e. [email protected]). I have set up a forwarding rule on my organisations mail box to forward mails to my personal Gmail, and I would like Gmail to label those emails.

I have used the rule deliveredto: [email protected], and it works for most emails, but the ones that hide the destination (such as mailing lists) do not get labeled as the rule does not recognize them.

The ideal solution would be one rule that would encapsulate all email that were forwarded (why can't google add a simple that is forwarded?), but a second-best one where it picks mailing lists would also be great!.

I would also like to avoid a solution such as "contains @organisation.com" because I also receive emails from my organisation(@organisation.com) on my personal Gmail account.

3 Answers 3

4

Setup your forwarding rule to redirect your [email protected] emails to [email protected].

In your personal account, have your labeling filter match against deliveredto:"[email protected]". Make sure to include the quotes.

I also noticed in your question that you included a space after the : in your labeling rule. There should not be one.

3
  • Hi, could you explain what is going on with this setup? I tried setting it up, but it's not really working. When you say to set up the forwarding rule to personal+organisation, if my email were [email protected], then i would set it up as personal+foobar, not personal+foo, correct?
    – cosmia1
    Commented May 23, 2017 at 17:44
  • In any case, I tried both ways (personal+foobar and personal+foo) and gmail doesnt recognize the deliveredto rule
    – cosmia1
    Commented May 23, 2017 at 17:51
  • 1
    I was using the exact terms you gave in your Question. But you can put whatever you like after the +, as long as you match against the same string in your labeling rule.
    – user13779
    Commented May 23, 2017 at 19:04
1

This info may help

The "Label incoming messages" option seems to be the part you're after. Rather than applying a label to emails that match the filter, it applies it to messages retrieved from the inbox.

See how you go, happy to help if needed.

1
  • thanks for the answer, this solution was my previous setup, but for some reason, gmail has some problem when authenticating, and I have to keep updating the setup.
    – cosmia1
    Commented May 23, 2017 at 17:46
0

I had a similar problem and the following solution works.

The specific setting: I am forwarding from Outlook 365 to Gmail (to [email protected], from your example). The deliveredto:"[email protected]" setup did not work at first: Gmail did not find the emails.

What worked: I changed from forwarding in Outlook to a filter. Forwarding is a separate item in settings (Settings/Email/Forwarding), different from rules / filters (Settings/Email/Rules). When I created a rule / filter to redirect all email to [email protected], in Gmail, the deliveredto filter started finding these messages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.