Some of my mail is handled by a third party. Every email I send using that party has a Blind Carbon Copies (BCC) to myself @ my third party's email address. All mail at the third party is forwarded to my Gmail account.
So I'm not using Gmail to send any message. And Gmail is just receiving forwarded messages including the BCCs.

The BCC messages appear in Gmail, however, they have no label at all (also no INBOX label). These BCC messages can only be viewed in Gmail's forlders All Mail and Sent Mail. This only happens with mail sent from my iPhone. When sending mail from my windows PC using Thunderbird, every BCC message gets an INBOX label only, it does not appear in Gmail's Sent folder.

I don't use skip inbox. Conversation View is OFF. I have tried filters like BCC:xxx and deliveredto:[email protected] , even regular ones like to:xxx or from:xxx . No filter works on those BCC messages, it looks like they are automatically archived. The problem is that I cannot download those BCCs either (as a check that they have been sent).

Any suggestion how I can get those messages labeled and/or download them to my iPhone using IMAP?

  • Try the deliveredto: search switch to find those messages.
    – ale
    Jun 2, 2017 at 15:32
  • I tried that one too. All tries I did, work on finding and re-labeling. They don't work on new messages arriving.
    – Dick99999
    Jun 2, 2017 at 15:36
  • Do the messages get the Sent label?
    – ale
    Jun 2, 2017 at 15:38
  • No label at all, (and not sent form my Gmail account). However, just to be sure I tried deliveredto:[email protected] and now they appear with an INBOX label. (not the MYBCC and Starred label I setup in the filter). Is there perhaps a hefty delay before a filter works?
    – Dick99999
    Jun 2, 2017 at 15:46
  • Sorry, they appear in the sent folder. That isn't a label I presume. Would it be possible that the issue is IMAP? That puts the message in sent locally on my iPhone and that would than interfere with Gmail labeling?
    – Dick99999
    Jun 2, 2017 at 15:53

1 Answer 1


Inspired by a post from 2012 on the Gmail Help Forum emails going to All Mail but not Inbox; possibly resolved...? ), I experimented with IMAP on my iPhone. The setting on my iPhone that interfered with Gmail labeling is:
Settings/Mail/Accounts/..my Gmail account../Account/Advanced/Sent Mailbox
That page offers a choice between 'ON MY IPHONE ' and 'ON THE SERVER' (the latter then lists all IMAP folders). I switched to 'On my iPhone' and the issue was gone. Now all BCC messages that are forwarded to Gmail by my iPhone, get a label INBOX and they appear in the inbox of my iPhone as a result of IMAP syncing.
My iPhone now behaves like my PC when Thunderbird sends BCC messages to my third party's account that forwards all messages to Gmail.

What probably happens with the 'On the server' setting is that Gmail recognizes the incoming BCC email as a duplicate of one already in the Gmail's Sent Mail box, a 'folder' that is synced by IMAP, and decides to skip the incoming duplicate message. Or this duplicate recognition happens later when syncing that IMAP folder. It's a pity that one cannot see which filter/event causes Gmail to label or skip emails.

  • Hi. Did you manage to get this fixed? I am experiencing the same.
    – Cy.
    Apr 15 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.