0

Just to elaborate on that, I typed out an email on Word and copied it to Yahoo Mail and I noticed that one paragraph had been hyperlinked automatically! There isn't supposed to be a hyperlink there! So, I deleted the text and typed it out again on Yahoo Mail and there was that hyperlink again. This happened several times, but eventually it allowed me to type it without a hyperlink. But after sending it, the same paragraph was hyperlinked again!

I tried clicking the link and it doesn't go anywhere. I tried copying the email text to Word and editing the hyperlink, but it just showed me that the link was empty.

I tried opening it on my Android phone - tapping the link opened a blank chrome tab, but long-pressing the link gave me this x-thread://-76874911/10984

There is no reason for the software to assume that it is a link. The entire para is just plain text, like "Once upon a time, email got weird etc. etc."

Any idea what that is? Or why some random text on my email got hyperlinked?

  • 1
    You didn't tell us what the text was, or even what format, so we've nothing to work with – Tetsujin May 29 '17 at 8:56
  • @Tetsujin Oh sorry about that. I had no idea where to start with this question, so didn't know what would help! Well, the text is a little confidential, but what do you mean by format? – Umar Ghouse May 29 '17 at 8:59
  • I mean you don't need to put the exact text, but we need to know if you wrote 'fred bloggs went shopping' or 'something://some text' - the first would be odd, the second a perfect reason for the software to assume a link – Tetsujin May 29 '17 at 9:03
  • Ah, OK. it was just plain text, similar to your first example 'fred bloggs went shopping'. No reason for the software to assume a link. The strangest part is that the link begins at a random point on the first line of the para and ends at a random point near the last line of the para. I've edited the question to address this, thanks! :) – Umar Ghouse May 29 '17 at 9:07
  • 1
    At the moment even though it worked it would be a partial answer - I'd love to know what Word thought it ought to be copying that it shouldn't. Do you have any other plaintext environments you could test that might possibly show up the RTF when you paste in? It would make the final answer so much more complete. – Tetsujin May 29 '17 at 9:55
0

This is a bit of a guesswork answer, based on the Q&A in comments. Feel free to add further detail if anyone knows how this may have happened.

My initial guess was that Word had some invisible embedded RTF instructions or similar, that it was carrying over in the copy/paste.

Experimentation has proven this to be the most likely explanation - though the 'why' remains elusive.

The 'simple fix' is to copy/paste from Word into any app that can only handle plaintext, then copy/paste back again, based on the theory that the 'RTF' data would either be exposed by this method, or discarded entirely.

This appears to be totally successful.

However, as the extra data causing the issue seems to be completely discarded in the copy via plaintext, I can't figure out exactly what is was that caused the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.