12

Google Apps for Domains used to have a catch-all feature. Now the docs say:

If you’re using another G Suite edition, the Email routing setting with the Route to catch-all address control is no longer supported. Instead, you use the Routing setting to configure catch-all addresses and routing.

but they don't actually have any instructions on how to do it.

Specifically I want to replicate the old behavior which is that if someone sends a message to [email protected] it gets forwarded to [email protected] in such a way that [email protected] can setup accounts in Gmail and can reply to the messages as [email protected].

If I check my legacy Google Apps for Your Domain emails and check the headers of a message sent to [email protected] I see absolutely nothing in the header that suggests it was forwarded to [email protected] and yet the mails show up in the inbox for [email protected]. This is important because when I reply, if I've added the [email protected] to my accounts under Settings>Accounts->Send Mail As... then I'm able to reply as [email protected] and not as [email protected]. For this to continue to work I assume the mail still has to be marked as to: [email protected] and not to: [email protected].

1
  • I'm rather curious about this as well, since I have a legacy account where I have the old behavior set up and a new account where I would like to have parity, being able to enable "reply from receiving address" in Gmail was fantastic, even though sadly the mobile client didn't know anything about that setting.
    – dragon788
    Commented Nov 10, 2017 at 14:58

4 Answers 4

11

This is just a guess but,

Under Apps > G Suite > Settings for GMail > Advanced Settings I added picked "Add Setting" with the following settings

  1. Specify envelope recipients to match: All Recipients
  2. If the envelope recipient matches the above, do the following

    • Modify message
    Headers
    • Add X-Gm-Original-To header
    Envelope recipient
    • catchall @ existing-domain
  3. Options

    • Perform this action only on non-recognized addresses

and it kind of works although it leaks [email protected] when replying with the following headers

spf=pass (google.com: domain of [email protected] designates ????:????:????:????::???? as permitted sender) [email protected]
Return-Path: <[email protected]>
Received: from mail-yb0-x22e.google.com (mail-yb0-x22e.google.com. [????:????:????:????::????])
        by mx.google.com with ESMTPS id y66si667532ybc.27.2017.06.15.00.51.39
        for <[email protected]>
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Thu, 15 Jun 2017 00:51:39 -0700 (PDT)
Received-SPF: pass (google.com: domain of [email protected] designates ????:????:????:????::???? as permitted sender) client-ip=????:????:????:????::????;
Authentication-Results: mx.google.com;
       dkim=pass [email protected] header.b=aFbgG/RI;
       spf=pass (google.com: domain of [email protected] designates ????:????:????:????::???? as permitted sender) [email protected]
...
From: Admin <[email protected]>
To: Test <[email protected]>

which I'd like to avoid

3
  • 1
    Thanks for the answer. The only one I found so far that gave instructions for setting up catch-all with routing. Worked for me. My option names were a bit different though: 1. Messages to affect: Inbound 3. Modify Message: Add X-Gm-Original-To header. 3. Change Envelope Recipient -> Replace recipient (entered email address to forward catch-all to). Show Options -> B-> Account type to affect -> Unrecognized / Catch-all
    – Anupam
    Commented Jul 29, 2017 at 11:00
  • find the section "Set up a catch-all address" here support.google.com/a/answer/2685650?hl=en Commented Feb 18, 2020 at 4:46
  • Changing the envelope recipient breaks SPF. It used to be that they would rewrite the Return-Path header to fix this, but no longer. On one of my free, grandfathered accounts, the behaviour was working until last week; after switching off catch-all and switching on again, it no longer updates Return-Path. Another account, upgraded to the paid edition last week, also lacks this capability. Annoyingly I missed this in testing because I emailed from another Gmail account and SPF passed anyway. Test with mail from a free Outlook account and you'll see it.
    – fazy
    Commented Jan 22, 2022 at 11:27
4

Just wanted to add where I finally found the old forwarding option in GSuite.

  • Admin Console.
  • Click Main menu ( three lines ) in top left, hover over Apps, click GSuite.
  • In the GSuite services list click Gmail.
  • In the Gmail settings menu, scroll to the bottom and click Advanced settings.
  • In the Advanced settings, General settings tab, scroll to bottom.
  • There is a routing section with the 'Catch-all' 'Forward the email to' setting.
4
  • Perfect, that worked! I hope this can be selected as the answer, but the title of the question is asking something else (even though probably this is what they actually hoped for)
    – mdiehl13
    Commented Jul 5, 2019 at 17:18
  • It looks like this was removed at some point
    – Chris H.
    Commented Dec 16, 2019 at 16:47
  • @ChrisH. I just checked my GSuite and the option is still there in the same place, but it's possible that it's been removed for newer accounts.
    – WhoIsRich
    Commented Dec 16, 2019 at 17:56
  • 1
    Ah, yes, I just checked an old G Suite account and it is there, but it is not there on my new G Suite account.
    – Chris H.
    Commented Dec 16, 2019 at 19:00
2

https://support.google.com/a/answer/2685650

You can create a catch-all address to ensure that messages that are accidentally addressed to an incorrect email address for a domain can still be received.

The following procedure describes the basic steps for setting up a catch-all address using the Routing setting. For details about all of the Routing setting controls, see Set up routing for your domain or organization.

To set up a catch-all address:

Do the initial steps to log in, select the organization if necessary, open the Routing setting, and enter a description for the new setting.

For email messages to affect, select Inbound, Internal-receiving, or both.

Set up an envelope filter if you want the rule to affect only specific envelope senders and recipients. You can specify single recipients by entering an email address for that user. You can also specify groups.

Under For the above types of messages, select Modify message.

Under Envelope recipient, select Change envelope recipient.

Select Enter new username.

Enter a catch-all address in the empty field next to @exisiting-domain. For example, enter jsmith.

Click Show options.

Under Account types to affect, check the Unrecognized / Catch-all box. Uncheck Users and Groups.

Click Add setting.

Save the configuration.

1
  • 2
    Hi, to improve the answer and make it fit the site standards, please write the full answer here (you can quote what's relevant), and state this link as your source. That way, if the link changes in the future - the answer is still valid Commented Jun 25, 2018 at 7:56
-1

I found the setting....

Goto the menu that allows you to do the above and scroll down to advanced settings.....bottom of that screen is a catch all setting!

BOOM!

1
  • 5
    Can you elaborate on this a bit, like maybe with a screenshot and less "BOOM"?
    – jonsca
    Commented Apr 4, 2018 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.