I enabled Markdown on wordpress.com as per Can't get markdown to work on wordpress.com

But it is not actually markdown. When I look at the Preview, it is inserting <br> when there is a line break in the markdown source. E.g.

This is a *paragraph*.
It is all one paragraph.  Nor is it a poem.

is converted to

<p>This is a <em>paragraph</em>.<br>
It is all one paragraph.  Nor is it a poem.</p>

Here is how Stack Exchange interprets the same Markdown source code, in accordance with the specification:

This is a paragraph. It is all one paragraph. Nor is it a poem.

Is this documented somewhere? Did it change? Was it intentional? I'd be interested if there's a workaround for wordpress.com, to handle line breaks correctly.


1 Answer 1


WordPress's default HTML-like input format is made more convenient by the wpautop filter, so as not to require explicit <p> or <br> elements in most cases. Unfortunately this means the Markdown option is also affected. This was how it worked from the start.

The options to disable this are not available on WordPress.com.

The convenient input format isn't a formal standard, and I don't know a standard tool to convert HTML or Markdown into it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.