4

Twitter keeps on showing me "Live video" on the right column, usually with some sports or esports.

Right now I keep seeing "Wimbledon live". Even when I click on "Hide", on reload, I see it again.

I have never shown interest in tennis or Wimbledon, and I have no idea how it's related to Twitter at all.

How do I turn it off? I have searched Twitter documentation and settings, and I don't see anything about these live videos.

1 Answer 1

1

Click on Profile & Settings (top right avatar image) then Settings and privacy. In the section Content there is a checkbox labeled Video Tweets: Video autoplay. Uncheck it, Save and voila, Live videos are gone.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.