2

Can't access Gmail account adamsfreeman@gmail.com. When security question appears, it's in a different language. Looks to be some Asian language. Not sure what to do.

  • 1
    Google doesn't ask any "security questions". Also: Enable 2FA. – Martin Schröder Jul 22 '17 at 11:13
2

Try to change the language. See below.

.

Hope this help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.