I am trying to create a Google Form. I am unfamiliar with Google Forms, but I am familiar with Google Sheets and Docs. I'm having a problem with the form, however.

When I go to the Sharing Settings for the form, and change who has access, the options show up properly. If I select any of the 'on' settings, however, there is no pull-down to select 'can view' as there should be. The only option is 'can edit'. I do not want this option, as then anyone I send the form to can change its structure outright.

Turning the sharing off doesn't work, as placing the link into a different browser (and different Google account) simply returns a message that I don't have permission to view the form. I did some research, and someone said to leave the sharing off and simply get the URL from the 'view live form' button. That button exists only in the old forms, so I switched back to that with the form, clicked the button, got the link, pasted it into the other browser, and was still told I didn't have permission.

I can find nothing in Google about this problem that has worked.

Either I'm doing something wrong or Google Forms are unusable. Is it a bug or am I just missing a step?


1 Answer 1


When viewing the form, click "Send" in upper right:


and choose the "link" option:


This gives you a link that you can send to anyone, and they will be able to access the form without logging in (unless you insist on collecting identities or controlling whether they take the survey more than once). It also has the structure

 https://docs.google.com/forms/d/e/ .... /viewform

but is different from the link you have when viewing the form yourself. Google also offers to shorten the link in case this is preferable.

  • Key phrase: "unless you insist on collecting identities or controlling whether they take the survey more than once". This was apparently the problem. The Google account I was using was linked to a website, and the form was requiring a login to that website. Why it doesn't simply offer the option to log in, I don't know, but unchecking it in the settings fixed the problem. Thanks Alex. Commented Jul 28, 2017 at 5:29
  • How do I allow people to view the questions and answers without sending it? I'd want them to be able to make their own copy to edit, but not edit my copy. Commented Nov 26, 2018 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.