13

I have two separate mailboxes setup with Gmail: 'emailA@gmail.com' which is available publicly, and emailB@gmail.com which I keep private.

Any email invitations sent to emailA@gmail.com are auto-forwarded to emailB@gmail.com. However, when I try to accept an invitation, I am unable to accept it.

"Ooops! It looks like you're trying to access this event using emailB@gmail.com"

Note that, while similar, this is not the same issue as “Google Calendar invitations cannot be forwarded via email.”, as that applies to forwarding invites between emails hosted by different organizations. (x@company.edu vs y@gmail.com)

I would like to avoid using the "Add to calendar" button, as it does not send notifications to the event organizer that I have RSVP'd.

How can I setup Gmail to let me accept Google Calendar invitations from my alternate email?

1

4 Answers 4

8

Google's instructions for this are inconsistent and split across a few different articles: Set up an alternate email, and allow responding to events from an alternate email, etc.

I've adapted and consolidated Google's official instructions below, but bizzarly their instructions only seem to work with non-Google email addresses (@hotmail, @yahoo, etc)

Important notes:

  • This will not work for accounts hosted through work, school, or other organizations. (x@company.org, y@school.edu) (see Google Calendar invitations cannot be forwarded via email)
  • The settings for responding to forwarded email invitations will be hidden if you have not set up an alternate email address.

Setting up an alternate email

  1. Sign in to My Account.
  2. In the "Personal info & privacy" section, select Your personal info.
  3. Choose Email.
  4. Select Alternate emails.
  5. If asked, verify your current username and password.
  6. Select either Add alternate email or Add other email. Enter an email address you own and select Add.

Allow forwarding from your alternate address

  1. On your computer, open Google Calendar.
  2. In the top right, click Settings Settings.
  3. Select your primary calendar from the left-hand Settings for my calendars menu.
  4. Find the General notifications section.
  5. Check the box for Allow responding to invitations forwarded through alternative email addresses. Note, it may take a little while after adding an alternate email for this setting to appear.

After you turn on this setting, you can use your Google Account to respond to event invitations forwarded from your alternate email address. Event responses will display as coming from your Google Account, not the alternate email address which was originally invited to the event.

1
  • 2
    Event responses will display as coming from your Google Account, not the alternate email address which was originally invited to the event. — This is the problem. I want the response to be seen as coming from the alternate email address.
    – ayjay
    Aug 11, 2020 at 17:31
7

In the new Google Calendar settings interface, the requisite "respond to forwarded events" setting described by Stevoisiak's answer is found under the General Notifications category of settings accessed by selecting your main calendar in the left-side menu.

Note, it can take some time before the setting shows up in GCal after you've added and verified your alternate email address.

General notifications

2
  • 1
    How long before the changes take effect? I followed the steps and checked the tick box. However, when i sent an outlook calendar invite test, the response being sent back is still from my gmail account and not the alternate email.
    – ayjay
    Aug 10, 2020 at 20:15
  • 3
    Unfortunately, I can not seem to find the option. The options from the screenshot are now under Other notifications, but the checkbox option is not to be found.
    – Jarno
    Feb 21, 2021 at 19:48
2

Another quick method is to right click on the Yes, Maybe, or No link and select "Copy Link address". Then, in another browser logged into the other Alternate e-mail address account, paste the URL into a new tab. Right Click on Yes, Maybe, or No and Copy Link Address

0

Google's instructions are not only inconsistent but incorrect in some cases. I have been using gmail since 2005 or 2006, got my gmail address, and later added an alternate address from my German GMX domain to my google account.

When I tried to follow the instructions, I found out that there is no such option "allow responding to invitations forwarded through alternative email addresses" in my settings.

To solve the problem, I have filed a Google calendar support issue here: How to prevent 404 error in gsuite calendar when accepting ics invitation sent to my alternate @gmx..

Please note that I have to post this as an answer, as I have no capability to post comments in the webapps stackexchange yet, so please consider this before downvoting. I plan to update my answer once my case will be successfully solved!

Not the answer you're looking for? Browse other questions tagged or ask your own question.