1

I have an unconditional forwarding address set up for a Gmail account:

Forward a copy of incoming mail to: email1@mydomain.com and keep copy in inbox"

I also have a filter that forwards email with specific strings in the subject to a different address (email2).

What I expect to happen is this:

forward to email1
if (filtermatches) {
   forward to email2 
   }

What is actually happening is:

if (filtermatches) {
   forward to email2 
   } else {
   forward to email1
   }

I thought it would be possible work around this by adding an additional "forward to email1" to the existing filter. However that does not seem to be possible. When editing the filter is a selector that allows a choice of either email1 or email2.

There is a link for "add forwarding address". Clicking on it closes the filter edit dialog box, and displays the main settings tab for "Forwarding and POP/IMAP". This is where the forwarding for email1 is already configured.

How can unconditional forwarding to one address be accomplished with filter-based forwarding to a different address?

1

You should be able to setup both the unconditional forwarding rule and filtered forwarding rule in Gmail as described and see this kick in.

Just to clarify, below is the description of the desired behavior and steps to get it configured.

  • forward (unconditionally/everything) to email1

  • if (filtermatches) { also forward to email2 }

The steps to get this configured are:

  1. Add/Register/Verify each forwarding address:

    • Gmail's Settings > Forwarding and POP/IMAP > Add a Forwarding Address (button)

    • Note - adding the forwarding address does not automatically set mail to forward to it; it only adds an email address to the list of forwarding options. does not actually set mail to forward, only adds an email option to the forwarding list

    • Note - you can add multiple addresses, but only ever select one per forwarding rule; you will need to verify each forwarding email address option you will need to verify each forwarding email address option

  2. Configure the unconditional forwarding rule:

    • Gmail's Settings > Forwarding and POP/IMAP

Unconditional Forwarding of all email to this Gmail Account

  1. Configure the filter and set to forward to email2, since email 1 will already receive the message from the unconditional forwarding set in #2.

Additional Conditional Forwarding

|improve this answer|||||
  • Thank you for the reply. That is exactly what I have done. However I am not seeing the unconditional forwarding. Are you seeing this work successfully in your case? Do you have any messages that come from mailing lists or reflectors (e.g. where your address is not in the To: or CC: fields)? – tim11g Nov 9 '17 at 13:46
  • I am seeing the unconditional forwarding kick in for all messages other than those that are flagged as spam. You could try adding those types of emails to your safe senders/contacts on the mail account. – Anson W Han Nov 9 '17 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.