1

I'm from Poland. And Google persistently redirect me to Google.pl.

Now if I go to Google.com, it will redirect me to Google.pl, unless I go to Google.com/ncr, in which case it doesn't.

But how can I go to Google.es? Typing just Google.es used to work, until a few days ago. Now Google.es persistently redirects me to Google.pl. I tried Google.es/ncr, but this doesn't help either.

According to Google, does the fact that I reside in Poland mean that I have no wish to search Spanish internet or shouldn't be allowed to do so?

  • @pnuts Sometimes I would also be able to search Polish internet. Argh, do I have to go into settings and look for the relevant settings each time I'd like to change language I want to search Internet in! Back in the old days it was so convenient, simply change the suffix in the address... – gaazkam Nov 25 '17 at 20:04
  • 1
    @pnuts For me Google.es in the address box works. Double checked. No luck for me. Maybe your issue is temporary. Maybe, though somehow I doubt it. Zeitgeist, dammit. Are your setting Poland or Current Region Current region. Changed to Spain, works. Now I suddenly have to go through more clicks whenever I want to search the Internet in Polish again. – gaazkam Nov 25 '17 at 20:15
  • I'm not able to reproduce the problem. I'm in Mexico, if I wrote google.pl it takes me to google.pl, if I wrote google.es it takes me to google.es and so on. – Rubén Nov 25 '17 at 20:25
  • You might also try using a different DNS server. – user3169 Nov 26 '17 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.