12

I work at a university. All students get a third party Gmail and Google Apps account but staff do not. Now I can't administer my domains that are expiring. Every time I try to go to admin.google.com to login to my domain account it redirects to my university login, which I can log into it, but then it errors out because as staff I do not have a Google Apps account.

I can't figure out where or how to turn this off.

Can someone point in the right direction?

3
  • 1
    Try using Chrome in incognito mode.
    – Rubén
    Dec 25 '17 at 18:53
  • 1
    @Rubén that worked, but would be nice to turn the damn thing off without opening a new incognito every time I want to manage my personal domains. Jan 9 '18 at 18:11
  • I have a similar problem. My laptop used to be a work laptop, now it is not. However, Safari still redirects me to the GSuite page. How do I turn this off?
    – Valentyn
    Mar 16 '20 at 2:46
10

I don't have a reason for it, but I think I have a solution.

Workaround

You can navigate to:

https://accounts.google.com/AccountChooser?service=wise&continue=https://admin.google.com

And it will let you choose the relevant Google account.

Or you can navigate directly to https://admin.google.com/accountchooser?u=YOUR_ADMIN_EMAIL_ADDRESS


By the way, it happens also to me - I have a university Google account but I'm not an admin and has nothing to manage there.


Side note: I'm using the AccountChooser link as a bookmarklet with a short js, to let me easily choose specific accounts for specific links.

6

You can also fix this without clearing all your cookies if you leave your university (or other "G Suite" accounts)—just delete your Google "Sign In" cookies.

In Chrome, you can do this by going to chrome://settings/cookies/detail?site=accounts.google.com&search=cookies and just deleting all cookies on it. You'll have to resign into Google accounts that you want to keep—but you won't ever have to deal with e.g. Google Meet repeatedly forcing you to login to a university or business account that you no longer have access to (and you won't have relogin to every account you ever used on that browser).

0
  1. Sign out of ALL G-mail accounts.
  2. Navigate to the sign on page.
  3. Choose the account you want to be the default and sign into it. If you are redirected to the university's login page again, click the link below to choose your sign on.Or just google, "choose my gmail sign on".

https://accounts.google.com/Login/signinchooser?flowName=GlifWebSignIn&flowEntry=ServiceLogin

G-mail automatically makes whichever account is signed into first the default account.

-1

Finally! I have had this problem for so long I can't even remember how long. Finally had enough and sat here for an hour to fix it. Clearing my history on Safari did the trick.

-2

If you're using Internet Explorer, the cookies can be cleared according to this website:

https://support.microsoft.com/en-us/help/278835/how-to-delete-cookie-files-in-internet-explorer

(It may be beneficial to have the "Preserve Favorites website data" at the top of the list unchecked)

For Google Chrome, this website may help in clearing cookies:

https://support.google.com/accounts/answer/32050?hl=en

Not the answer you're looking for? Browse other questions tagged or ask your own question.