4

I have Amazon Prime in Canada.

  • I'm logged into my Amazon.ca account
  • I can login and access Prime Video in Canada.
  • I try and access Prime Music, but am redirected to Amazon.com, where it logs me into my Amazon.com account, and says I have "No membership"

How can I fix this?

I've tried logging into my account from an incognito browser, with no help.

  • 1
    Is your device connecting via a US IP address? If so, Amazon may be redirecting you to the geographically appropriate Amazon URL. – JW8 Jan 5 '18 at 4:14
  • Good point - but no, I'm not using any VPNs and am in Canada – Brad Parks Jan 5 '18 at 12:53
1

The solution turned out to be easy - I just called Amazon support, and they fixed it up within 10 minutes. I didnt think it'd be easy to reach their support and get such awesome response times, but I guess I was wrong.

So long story short - try the Amazon support customer line! https://www.amazon.ca/gp/help/customer/

| improve this answer | |
1

I know this thread is a little old, but I'm posted in case this helps someone in the future.

  • Go to the top right corner in your Amazon.ca account, and click "Your Account" under "Account & Lists".
  • Under "Digital content and devices", click "Music Settings".
  • Right at the bottom, you should see "Your Amazon Music Account is currently in US. Move your music account."
  • Click on "Move your music account".
  • You'll have the option to move it to Canada (or whatever other country you like).
  • This change should take immediately.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.