2

Up until yesterday, documents looking like this (note the 2, 3, then 4 newlines between letters):

a

b


c



d

Would be copied and pasted in plain text (e.g. in a plain text area on a web page, or a plain text editor like VSCode or GEdit) just like they look in the document, and just as I typed them (pressing Enter twice at the end of a line, no "after paragraph" spacing tomfoolery.)

As of Jan 11th, 2018, it seems the exact same document (and every other document I've tried so far) now gets copied with double newlines stripped down to single ones:

a
b
c
d

Context

For my particular use case this is really annoying, because I'm editing Markdown and this necessitates an extra regex replacement to put all the newlines back every time I change a document. Since I often make changes using the Google Doc as the "single source of truth" (because of its collaboration and history features), then copy and paste them into another context where they're actually used, this would mean adding a hundred regex replacements to my daily workflow for nothing.

What I've tried (to no avail)

  1. Installing the Docs Offline plugin, the one you're annoyingly prompted to install whenever you use Copy from the context menu instead of Ctrl+C, and reloading the page.
  2. Restarting my computer completely (and not restoring tabs, using fresh ones for any Google Docs attempts.)
  3. Using Firefox instead of Chromium (and Firefox never had this problem before today, either).
  4. Asking a colleague to try this in Windows (I'm using Linux Mint)--it's also broken there (for him, at least, contrary to one commenter's experience, perhaps due to inconsistent rollout from Google? I have no idea.)

Why did they change it? Will they change it back?

  • 1
    Only Google knows why. It may very well be a bug. Use the "Send feedback" tool to let them know about it. – ale Jan 11 '18 at 17:55
  • 1
    I was not able to reproduce the problem by using Chrome and Notepad for Windows 10. – Rubén Jan 11 '18 at 18:11
  • 2
    Same thing happens to me copying from Google Doc in Chrome/Win7 to Notepad and VS Code. Interestingly, copying to an online editor (either a different Google Doc or another site like ZenPen.io) retains the original formatting. – freginold Jan 12 '18 at 15:49
  • 1
    @freginold thanks for confirming. I'm also seeing that it survives copying directly between Google Docs OK (I hadn't thought to check that yesterday; unfortunately it doesn't help my particular use case. I guess it's because it gets copied and pasted as HTML when going between "rich text" contexts.) – Kev Jan 12 '18 at 15:54
  • 1
    Have you tried to download the file as plain text? – Rubén Jan 12 '18 at 16:33
0

"The first thing to try" when this kind of situations occurs with a web application is to check if the problem persist using the browser in incognito / safe mode with all the extensions disabled in order to discard that the cause of the problem be the cache, cookies or an extension.

As a workaround, download the file as plain text: File > Download as ... > Plain Text (.txt)


The problem could be related to the fact that applications could use different ways to set a new line.

  • Some applications use \n
  • Other use \r\n

The above could be inherited from the operative system, could be set by the developer.

Another cause could be related to the interaction of the user environment:

  • Operative System
  • Web browser
  • Web browser plug-ins / extensions
  • Web application
  • Installed application
  • ...

Reference

  • 1
    I'm not sure this explains it, given that it's happening (for those users its happening to) on both Windows and Linux, and all plain-text paste locations (browser-rendered <textarea>s, multiple external editors) receive it the same way. Actually, I appreciate your attempt, but I think I have some conclusive evidence to the contrary--I'll update the question. – Kev Jan 12 '18 at 16:28
  • As you can see, no matter how many newlines you put, they get turned into one newline. This doesn't seem to match the 2->1 pattern that might be possible with \r\n/\n mixups. – Kev Jan 12 '18 at 16:31
0

Apparently as of today it's working again (at least on my end.) The advice I was given was to try it in an incognito window if I see it happen again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.