1

I've been having this annoying problem for quite a few months now.

If I am using Google Chrome (tested on a Mac and on Arch Linux), and I am also logged into my Google Account, if I go to https://google.com/maps , the map loads, but after a few milliseconds, just before the webapp finishes rendering, the map goes blank. I've done a screencast to explain:

Google Maps bug

  • This does not happen if I am not logged into my Google Account.
  • This also doesn't happen on Firefox.
  • I have not tested on Windows, but I'm pretty sure it would be the same.
  • I've also tried logging in while on an incognito session, and the problem reappears.
  • I've tried disabling all extensions and clearing the cache. Same result.
  • This does not happen if I log into two other different Google Accounts.

migrated from superuser.com Jan 25 '18 at 2:19

This question came from our site for computer enthusiasts and power users.

  • No repro on Windows 7 Home Premium 64 bit, Chrome 63.0.3239.132. – DavidPostill Jan 21 '18 at 21:12
  • Could you convert the YouTube video to a gif and embed it in the post? If you can embed, someone else will do this edit with the link that will be in the post – arieljannai May 31 '18 at 6:15
  • 1
    @arieljannai done! – Pablo Montepagano Jun 1 '18 at 0:11
3

In Chrome click on ‘Menu’ (3 Dots) menu visible in the upper right corner of your computer screen.

Next, select ‘Settings’ from the list of the options displayed there.

Thereafter scroll down to the bottom and choose ‘Advanced’.

When directed to a new page, look for an option that reads ‘Content Settings’. There, click on ‘Cookies’ and on the next page click “See all cookies and site data.”

Here, in the empty search bar type www.google.com and hit ‘Enter’ key.

The browser will list dozens of cookies specific to your browser and your Google account. The one that’s reported to be causing the issue is labeled “gsScrollPos.” but there are many of these so, you cannot pinpoint the specific cookie which is causing the trouble. Therefore, you’ll need to delete them all. Do this, by clicking the “X” icon on the left side of the settings column. Do this for all cookies with the gsScrollPos label.

When finished, launch Google Maps service again. It should now open normally.

  • Thank you!!!! I've been with this annoying issue for more than a year! This worked like a charm. – Pablo Montepagano Jun 1 '18 at 0:04
  • A slight update, for Google Maps circa July/Aug 2018. I encountered this problem for the second time, but this time there were no gsScrollPos cookies to clear out: maybe Maps changed their cookie structure. It still worked fine in Incognito Mode, though, suggesting it was still a cookie issue. So I deleted all the googleapis.com and similar "Google internal" cookies, and the maps now work again. Not a big change, but the guide quoted above isn't the whole story anymore. – andybuckley Aug 27 '18 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.