0

I am using Firefox Quantum 58.0.

My banking application (here CCP Connect Luxembourg) insists on popping up a completely unnecessary "undecorated window" (no toolbars or anything, on the other hand it has "facebook pixel" and "doubleclick ad exchange" trackers ... kornheiser_why.jpg) to prepare the user's login via 2-factor authentication. As I am using NoScript, and this window uses scripting, it stays blank, but I can't tell NoScript to whitelist this page as there is no NoScript icon on that window...

Let me demonstrate:

The CCP Connect Login Screen

Click on "Login":

The CCP Connect Popup Window

Ouch time!

(The screenshot has a black border because I wanted to capture both windows overlaid, which means I need to "select a rectangle"; can't capture a window tree yet)

What to do?

  • Have you tried using another browser? It this only happens on firefox it's very likely that the problem/solution is related to it and then the question could be better served on Super User. – Rubén Jan 28 '18 at 18:01
0

All right, it's actually simple if you know how to. The key lies in this mozillaZone article: Prevent websites from disabling new window features.

You have to tune the appropriate dom. disable_window_open_feature.* variable in about:config. There are quite a few:

  • close: Prevents the close button from being disabled.
  • directories: Prevents the bookmarks toolbar from being hidden.
  • location: Prevents the address bar from being hidden
  • menubar: Prevents the menubar from being hidden.
  • minimizable: Prevents popup window minimization from being disabled.
  • personalbar: Prevents the bookmarks toolbar from being hidden.
  • resizable: Prevents popup window resizing from being disabled.
  • scrollbars: Prevents the scrollbars on a popup from being disabled.
  • status: Prevents the status bar from being hidden.
  • titlebar: Prevents the title bar from being hidden.
  • toolbar: Prevents the navigation toolbar from being hidden.

It's the last one which is of interest here. So let's search for it in the about:config screen and toggle it to true:

Tune da Firefox, yo

This will preclude the banking application from switching off the toolbar like it owns the place:

We have a Toolbar

We can then tell NoScript to allow scripts from previously unknown origins (https://secure.ccp-connect.lu and https://orely.luxtrust.com), which makes the 2-factor auth screen appear:

A login screen appears, as it should

Happy banking!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.