My Chinese is still pretty poor, and my Korean is worse.  But Google Maps recently began showing me everything in Korean or Chinese.  Sometimes even a mixture of both. I can't find anything to change it.  My browser, if I don't catch it, switches me to maps.google.es, but that doesn’t make it Spanish.

I can follow an itinerary with difficulty, but choosing the best one it offers is a major problem.

How can I get it to do a language I am reasonably good at? (English or Spanish preferred.)

  • 1
    This is relevant for travel. Google, by default, has the tendency to ass/u/me that the primary language of the place one is in is the language one would prefer to receive their services in. I've personally witnessed this when Google suddenly started talking in Spanish to me. In that case, it wasn't a problem for me, but it could have been if Google had instead assumed that I know Azerbaijani.
    – Robert Columbia
    Feb 14, 2018 at 14:05

1 Answer 1



enter image description here


  1. Click on the Menu bar on Top Left.
  2. Click Language.  It's the second one after Print, with the 文A icon
  3. Set it to your liking.
  4. Enjoy!

For example i just changed my language to Deutsch and now i see directions like this

enter image description here

  • 1
    Yep, that worked. I did feel the need to add an important detail for anyone else faced with an incomprehensible UI (which does not include their language’s word for "language").
    – WGroleau
    Feb 14, 2018 at 11:22
  • 1
    Any idea how to make this setting "stick"? I have to change it every time I load a new browser tab.
    – JBentley
    Jul 8, 2019 at 21:25
  • To make it sticky, go to your google prefereces page and click on the "Data & Personalization" menu on the left: myaccount.google.com/data-and-personalization. Then click on "Language" and make sure it's set to whatever language you want. Google will show a toast with a message like "Some products are not using English (United States)." and a button "Change All". Click on that button.
    – archmage
    Dec 1, 2019 at 13:22