1

I have been looking at twitter.com in Google Chrome browser, Version 64.0.3282.186 (Official Build) (64-bit). I use a number of extensions, all enabled except as noted:

  • BehindTheOverlay 0.1.3
  • Bookmarks Reorderer 2.0.1
  • CanvasFingerprintBlock 1.5
  • Cisco WebEx Extension 1.0.12 (not enabled)
  • Cookies 1.8.3
  • Docs 0.10 (not enabled)
  • Don't Fuck With Paste 1.1
  • EditThisCookie 1.4.3
  • Ghostery – Privacy Ad Blocker 8.0.8.1
  • Google Docs Offline 1.4 (not enabled)
  • Make America Kittens Again 1.2.2 (not enabled)
  • McAfee® WebAdvisor 5.1.0.633 (not enabled)
  • Mute Tabs By Url 3.0
  • MuteTab 3.0.9 (not enabled)
  • Official Media Bias Fact Check Icon 1.3.2
  • Privacy Badger 2018.2.5
  • Quick Javascript Switcher 1.4.1
  • RSS Feed Reader 7.3.6
  • RubberGlove 14.7.8.0 (not enabled)
  • Sheets 1.2 (not enabled)
  • Slides 0.10 (not enabled)
  • User-Agent Switcher for Google Chrome 1.9.0
  • WhatFont 2.1.0
  • Zotero Connector 5.0.35

I recently deleted all the cookies for twitter.com (using the EditThisCookie extension), and since then, whenever I open any page on twitter.com, the page opens and displays briefly, but a second or so later switches to mobile.twitter.com. All of these extensions were enabled before the twitter pages started switching to mobile.

I am not using a mobile device, although I do have an Android tablet connected via usb. (That connection also predates the current behavior.) I have tried turning off javascript on twitter.com, but has no effect. I have tried switching user agents, also without effect. I tried resetting the Chrome settings, also to no avail. I have tried logging on and off of twitter, but that makes no difference. Ditto blocking or deleting cookies.

I have searched the web for how to restore the standard view, but all the hits I've gotten relate to Google Chrome for mobile devices and most show menu items that do not appear in my browser. I have tried looking at the twitter page using the Chrome developer tools, but I haven't had any success there, either. I haven't found any sites besides twitter that exhibit the same behavior. I am able to see twitter.com, as opposed to mobile.twitter.com, in MS Edge.

Any suggestions would be appreciated.

  • Have you tried disabling all extensions and then loading Twitter? – freginold Mar 1 '18 at 18:38
  • 1
    Per your suggestion, I disabled all the extensions, and now the problem is solved. I didn't think to do that because the extensions were all enabled before and I never had a problem till I deleted all the cookies from twitter. I enabled all the extensions again one by one, but there was still no problem after all were enabled again. However, I tried deleting all the cookies again, and now the problem is back. I will experiment further. – jkozma Mar 2 '18 at 5:13
  • Actually looking for a way to force my browser to use the mobile website... since it's significantly faster than the regular twitter site. – Tracker1 Jun 27 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.