3

I got a new phone (OnepLus 5T) and since that on my home PC, WhatsApp Web constantly disconnects. No problem on my work PC. I use WhatsApp Web constantly and I find myself typing away but the messages wont go through. I get the yellow warning in the top right - usually it will reconnect after a minute or so and the messages will go through but the group conversation will have gone on without me seeing it unless I check my phone.

Any idea how I can fix this?

  • 2
    Did you get a new service provider? Perhaps the app on the phone is having a harder time "phoning home" from your home location versus your work location. Can you try using your PC from a different location in your house or, at least, put the phone somewhere with a better signal? – ale Mar 30 '18 at 11:54
  • Nope still the same provide, just a new phone! Its very annoying.. – Colly Fitz Mar 31 '18 at 13:16
1

I had the same problem also with Oneplus, and think I solved it.

Some other causes may be having 'disconnect WiFi during sleep' enabled, or having 'doze' settings on which will mess with your connection.

This wasn't the case for me, but in my case I'm guessing the problem concerned Battery Optimization. I had optimization enabled for Whatsapp which will restrict background activity of apps to improve battery life. Go to Battery > Battery Optimization > scroll down to the app Whatsapp > choose 'Don't Optimize'.

  • Is that not the same thing as the 'doze' setting, or is there another place where I can turn of dozing? Because this didn't work for me, I'm still having the same issue. – lucas Jul 21 '18 at 10:58
1

I will answer what did not work for me with my onePlus5t at OS Version 7.1.1 with several Versions of the WhatsApp Android App different Wifi Networks and Web Browsers:

- settings -> system -> developer options -> disabled doze mode
- settings -> battery -> Battery optimisation - > WhatsApp -> "dont optimize"
- Settings -> Apps -> Application List  -> WhatsApp -> Data Usage -> Checked option: Unrestricted use of data
- Settings -> Wifi -> Configure Wifi -> Keep Wi-Fi on during sleep -> Always

All of this changes did not solve the problem that "Phone not connected" appears randomly. It seems to be that "Whats App Web" reconnects often automatically after some time and also instantly if I open the WhatsApp Android App in the OnePlus Phone.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.