1

I have a friend, let's call her Sue.

She has a generic email, let's say it's SuesEmail@gmail.com

In my Gmail account, whenever I email her, Gmail autocompletes her email address, and gives it a human readable name as follows,

To: Sue Jones <SuesEmail@gmail.com>

Sue is now married, uses same email, and changed her last name to Smith. In my contacts, I've changed her name to Sue Smith. But Gmail continues to always autocomplete her name as:

To: Sue Jones <SuesEmail@gmail.com>

And every time I initiate an email to her, I have to edit the "TO" line, to read

To: Sue Smith <SuesEmail@gmail.com>

Is there a way to get Gmail to autocomplete using the correct name?

Several observations:

  • It's not the browser, as I see this in Firefox, internet explorer, clean installs of Chrome, and in the gmail android application.
  • Sue's Google+ profile has Sue Smith.
  • All emails from Sue, when examining the raw ASCII text format, have Sue Smith.
  • These things are notoriously difficult to suss out. Does she have a Google+ profile? Check the details of the headers in a message you've received from her; does her name appear correctly there? Could this be saved in your browser rather than Gmail? – ale Apr 10 '18 at 17:17
  • @ale It's not the browser, as I see this in firefox, internet explorer, clean installs of Chrome, and in the gmail android application. Google+ profile has Sue Smth. All emails from her, in the raw ASCII text format, have Sue Smith. – John Apr 11 '18 at 3:12
  • Comments are meant to be temporary. That's important information that should be in the question body. Please edit. – ale Apr 11 '18 at 13:22
1

If you already updated her info on your Gmail contacts and there is no duplicate entry, It sounds like this issue might be caused by Sue herself. Has Sue updated her last name within Gmail? It might be the result of Google looking for the contact SuesEmail@gmail.com and pulling her info from her profile or settings which still reads Sue Jones. I suggest you ask her if she has updated her info on the Gmail settings page.

  • Emails that originate from Sue come to me as Sue Smith <SuesEmail@gmail.com>. So, I don't think it's on her end. – John Apr 10 '18 at 16:18
  • Based on Michael's question, and Ale's comments, I double checked my contacts. I searched on "Sue" and found that indeed there were two contacts in my contact list, one for Sue Smith and one for Sue Jones. I can't believe I missed this, and was certain I had checked this earlier. This seems to solve the issue. – John Apr 11 '18 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.