8

I get too many irrelevant Facebook notifications from friends of the activities which do not involve me at all. This include status updates, posting pictures, sometime comment replies and what not. I am not sure if I get these from all friends or a chosen few.

This is what my notifications look like

enter image description here

These are my notification settings

enter image description here

I tried contacting Facebook support so many times. Never received any response.

"Get Notifications" option is already unchecked for these friends. I even tried enabling "Get Notifications" and then disabled it just to make Facebook aware of it but it didn't stop notifications.

It looks a like a way to keep me active but instead it has made me leave Facebook for a very long time. What settings should I do to disable these notifications?

  • 1
    I was also really annoyed by this. Facebook makes it ridiculously hard to find but I finally figured it out. You have to enable Desktop notifications then refresh the page and under the heading "CONTROL YOUR RECENT NOTIFICATIONS" (it's in all caps) turn off the ones you don't want. Then you can turn off Desktop notifications again. Would have posted this an answer but I don't have the required 10 reputation. – Patrick May 10 at 23:46
4

It's Facebooks way of getting you to use more Facebook. Which in your case, failed miserably.

They send these notifications to people who haven't had much of interaction on facebook to have a page full of notification.

Unfortunately, the way to get rid of these is to use more Facebook, get more friends and to interact with them. Just so that they can replace these notifications with something else.

Source: I've seen those when my mom signed up for Facebook and abandoned it for some days. Her notification was full of these craps.

  • 2
    That at least sort of answers the question! I used to use facebook all the time and these days I rarely do, but when I do it's full of all this crap! The stupid thing is that it makes me want to use it far less... – Some_Guy May 22 '18 at 21:48
2

As answered by Patrick in the comments of the question, they hid the turn off option too deep.

First, Enable desktop notifications

desktop notifications

Then disable recent notifications

disable recent notifications

1

Some friends are designated "close friends" and you get updated on everything they do. Try checking specific friends you get a lot of notifications from. Make sure they're not listed as close friends (Sometimes FB will do this without telling you).

Directions:
1. Go to the profile of the friend in question.
2. At the top of the profile, in the cover photo, locate the friend status dropdown menu. It's on its own row.
3. Change status from "close friends" to "friends" or "aquaintances."

You'll have to do this for each friend. Report back if it works!

  • 1
    "Close friends" was already unchecked. When I clicked on it, it changed to ☆ Friends on cover. I disabled it and changed back to ✓ Friends. I checked all friends, none of them is listed as Close Friend. – LifeH2O Apr 17 '18 at 8:30
  • Does making them acquaintances help? – Amelia Apr 17 '18 at 13:34
  • I now changed some friends to Acquaintances. Let's see if this works. – LifeH2O Apr 30 '18 at 8:01
  • 1
    I am still getting notifications from them after making them aquaintances – LifeH2O May 6 '18 at 4:27
0

First make sure that these friends are not added any kind of list like Close Friends or any Custom List.

You can turn off notifications for Close Friends:

You’ll automatically get notifications when people on your Close Friends list post to Facebook, but you can turn these notifications on or off:

  1. Click down arrow in the top-right and select Settings.
  2. Click Notifications in the left column.
  3. Click Close Friend Activity, then click On Facebook.
  4. Click next to Close Friends activity, then select On or Off

If you're getting notifications when people post and they aren't on your Close Friends list, learn how to receive fewer notifications.

If above doesn't help, try this:

On your phone:

  • Go to Account Settings
  • Go to Notifications
  • Go to Mobile Push under the section How You Get Notifications
  • Uncheck Activity you've missed and anything else you rather not be notified about
  • 1
    Close Friends notifications are already off. Mobile notifications are also off. I removed all friends from all lists. Still getting notified of everything. – LifeH2O Apr 27 '18 at 11:00

protected by Community Dec 26 '18 at 12:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.