2

I have contacts who have changed their email addresses. Autocomplete in Google Mail still includes those addresses although I have deleted them from my contacts list. How can I delete those individual addresses?

0

The problem I had with this is that there was no "Other Contacts" shown in my contact list so the problem email addresses didn't show up in a Search (or anywhere besides the auto-complete feature). After a lot of trial and error, I realized that my "Other Contacts" group didn't show up because I had changed the Gmail Settings for "Create contacts for auto-complete:" to "I'll add contacts myself". I couldn't see the auto-complete contacts anywhere, but the (incorrect) email addresses were still being shown when I started to type a name in the "To:" field of a new email.

To be able to delete (or correct) these incorrect auto-complete email addresses, I had to first change Gmail Settings for "Create contacts for auto-complete:" to "...add them to Other Contacts...". Then my Other Contacts group started showing up again still filled with over 200 outdated email addresses, which I was then able to delete as normal. After contacts were synced to my phone, the outdated email addresses were gone from the auto-complete feature there as well.

Once all the problem email addresses are deleted or corrected in "Other Contacts", you can change Settings for "Create contacts for auto-complete:" back to "I'll add contacts myself" again. Of course the "Other Contacts" group will again disappear but remaining email addresses will still be used with auto-complete for any existing "Other Contacts" that you didn't delete.

| improve this answer | |
0

It's included in the linked question, but make sure you go into contacts and search for the email address in question. We recently changed domain names at work, and I've been walking everyone through this process. The gotcha is usually that everyone in the directory (automatically created by Google) still gets listed in the 'Other Contacts' section of Contacts, because you've emailed (or received mail?) from them. So, there are literally hundreds of "contacts" with zero information on them.

  1. Go to Contacts
  2. Search for the email in question (in our case, for the @example.com domain)
  3. Scroll down to "Other Contacts"
  4. Select the top checkbox
  5. Scroll down, and holding Shift, select the bottom box, which should result in all of them being selected.
  6. Delete with extreme prejudice.
  7. Then go into actual contacts and edit/update as needed (it sounds like you already did this step).
| improve this answer | |
0

Thanks for solving my problem! I found that I didn't even have to change the Gmail Settings to see the 'other contacts' section. It was rather laborious to delete all of them, but there's a fairly fast way to do it:

  • Hover over the contact name
  • Click on the vertical dots to the right ('more actions')
  • Press down arrow twice to highlight 'delete', press 'enter', then 'enter' again to confirm

Using the right hand on the mouse and the left hand on the keyboard, you can do it pretty quickly - about 3 seconds per deletion, once you get into the rhythm of it. I deleted about 50 contacts in 10 minutes.

| improve this answer | |
-1

The easiest solution is to use Samsung Email app. Next to every email address in the drop down list is an x. To remove the address, click on the x. This removes that address from Samsung Email app but not from Gmail. I am disappointed that Gmail has not provided such a simple solution. However, I am not surprised because Gmail is not user friendly. Furthermore, the 'Gmail methods' would not remove all of the bad email addresses. Some addresses I could only remove in the Samsung Email app. I thought the option 'Gmail/Setting/Create contacts for autocomplete/I'll add contacts myself' would let me start from scratch, but it does not. And, what is the purpose of 'Other Contacts'. Also, with the 'g Gmail methods', you will have to fix every Gmail account.

| improve this answer | |
  • Welcome to Web Applications! Switching email providers isn't a viable option, I guess ... – Glorfindel Apr 26 at 8:34
  • I did not say change email providers. Samsung email is a email app that supports Gmail. When I want to send an email I will use Samsung email – Grog Klingon Apr 28 at 0:35
  • This problem has existed for years. Gmail could fix this problem. The simple solution is: for deletion put an x next to every item in the autocomplete list. For addition put a checkbox next to every email address in the Contact list. – Grog Klingon Apr 28 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.