I was trying to do a VLOOKUP in a column and print results of a column left to the on to be searched. So I tried put them into an Array to move the search column to the front. But for some reason the comma delimiter doesn't work in Formulas.

What I tried to do:

=VLOOKUP("search-term"; {B:B, A:A}; FALSE)

This results in a formula parse error, also the B:B Range is not colored. This also results in a formula parse error:

{B:B , A:A}

I can workaround by using:


But that gets really chaotic really fast. Is there a reason why the comma delimiter doesn't work?


1 Answer 1


You can't use , because of your locale. You should use \ instead.


Note: For countries that use commas as decimal separators (for example €1,00), commas would be replaced by backslashes (\) when creating arrays.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.