I can't seem to get formulas to execute in a Google spreadsheet. Whenever I input a formula, it does not return any output, but rather leaves the cell blank. I have tried the following troubleshooting:

  • Reducing my formulas to simple queries, such as =1+2. Note that before pressing enter to evaluate this formula, I was able to see the result above the entry box as "3". Pressing enter returned no output
  • Toggling Iterative Calculations and Recalculations in File>Spreadsheet Details
  • Reopening spreadsheet, reopening browser (Vivaldi, up to date), and rebooting computer. Note that I can use formulas in other spreadsheets perfectly normally, but every sheet within this spreadsheet will not return output to formulas.
  • Clearing formatting manually, and with Ctrl+\ (Font, font size, font color, cell color, etc). Note that entering values normally displays correctly; only formulas do not return any output.
  • Removing all Sheets addons
  • I do not own this spreadsheet (I'm an editor), however the owner is having the same problem.

Hopefully the problem lies in some simple menu I didn't know to check. But for now, I am completely stumped and have no idea how to troubleshoot anymore. Unfortunately I can't share this specific spreadsheet due to the content. I tried copying sheets from this spreadsheet into other spreadsheets, but the problem no longer appeared.

  • Have you checked script editor? Maybe some virus scripts running in background? Also, try editing it in mobile or offline?
    – TheMaster
    Commented Jul 8, 2018 at 7:40

4 Answers 4


It's a known issue that spreadsheets could become broken in such way that they can't be fixed in any way.

If you can't open and access the spreadsheet data anymore, then you should contact Google Sheets Support. Also you could try to use Google Apps Script or the Google Sheets API try to recover the data and formulas.

If you can open and access the spreadsheet data you could try the following:

  1. Change spreadsheet settings like Regional and time-zone settings. Wait few minutes and open again the spreadsheet to check if it's working fine after that.
  2. Restore an early version of the spreadsheet from the version history
  3. Make a copy of the spreadsheet
  4. Copy one sheet at a time to another spreadsheet
  5. Download the data by using a CSV, XLXS, or other file format.

If any of the above work for you, please left a comment and share what worked for you.



I had the same issue after I changed the language in Sheets. A simple refresh of the page resolved it for me.


This was happening to me as well.


  1. choose 'File'
  2. choose spreadsheet settings
  3. choose calculations
  4. turn 'iteration calculations' Off

I had the same issue.

The column that contains the formula/output, all had the Format "Auto", I change this column to "Number" and the results had populated!

Not the answer you're looking for? Browse other questions tagged or ask your own question.