Adding row to table using the table control is utterly frustrating. Only a cell is added to the table. Has anyone solved this?

enter image description here

enter image description here


2 Answers 2


Just tried and the row control seems buggy - anyhow if you double-click in the last cell, this control should be displayed somewhere:

enter image description here

Clicking the down arrow adds a new row.

I've tried to create an animated gif: enter image description here

As you can see, the controls are not displayed where they should and the images in the table are messy, but at least you get a full new row...

  • Interesting. I have tried both using draw io in the browser (chrome) and the desktop version but I cannot get the control to display no matter how much or where i press.
    – geogrow
    Jul 11, 2018 at 12:56
  • @geogrow I did it with firefox but didn't get the controls with chromium. Seems like a really buggy feature to me...
    – ponsfrilus
    Jul 12, 2018 at 9:46

Reposting this from a different page because this questions is asked about five times...

This was remarkably frustrating because the "Format Panel" that displays the table options doesn't pop up unless it's been previously activated:

To access the "Format Panel": create a table, click on the table, then...

  • Opt1: click the Grid icon (its directly under the draw.io icon) and select "Format Panel"
  • Opt2: CTRL+SHIFT+P

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.