0

As you can see in the following picture, firefox's language is German.

enter image description here

Searching for 'google maps' brings as first result www.google.de/map.

What i did was to follow the steps in this tutorial: https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack

  1. I have installed the English (US) version of the browser
  2. In the add-ons Manager, the Language panel shows English language pack enter image description here
  3. When trying to change the language of the user interface, i type about:config in the address bar; searching for ' intl.locale.requested' brings no result

There are other entries such as intl.accept_languages, but the tutorial does not use them. Anyway, this entry is set to English enter image description here

What can i do about this problem? While the location of my company is outside Germany, the website https://www.whoismyisp.org/ identifies the location of my ISP as a german city.

EDIT: I also tried this approach:

  1. I went to https://www.google.co.in/preferences?hl=en, and changed the Region Settings from Current Region to United States. Still the same result

2nd EDIT: several more attempts:

  1. I typed 'about:config' in the address bar, I added the entry 'intl.locale.requested' with the value 'en-GB', and I also modified the wifi uri to point to a New York location. I also set 'geo.enabled' to false, but the results are still in german. I did not forget to restart the browser after these changes.

enter image description here

As pointed out here , it appears that websites derive the location based on the IP address. The only way to bypass this is to use a proxy - which might be against my company's policy, and the internet connection is pretty slow already.

  • 5
    Firefox is in English, websites are in German. It's an important distinction, because these have completely different causes. – gronostaj Jul 10 '18 at 10:58
  • 2
    You're connecting from German IP, so google detects it and shows you german page. Go to google.co.uk to be sure to find google in English – DDS Jul 10 '18 at 11:01
  • even the page google.co.uk is in german – Newton fan 01 Jul 10 '18 at 11:21
  • Are you searching from Firefox’ address bar or search bar? – Daniel B Jul 10 '18 at 13:23
  • Honestly I think Google eliminated this kind of functionality in the last year or two. Now language and locality seem to be fixed by user location. Are you logged in to you account? Same logged in or out, or on a system where cookies and off-line data are not saved? – user3169 Jul 11 '18 at 3:43
3

Go to https://www.google.com/webhp?hl=en&gl=en

Underneath the buttons should be a line containing

Google offered in: English

There should be an English option

Click on English

  • The line containing "google offered in" only appears from time to time, its inconsistent, i don't know why it doesn't always appear. When it appeared, i was able to change the language to English, then I changed it back to German, i refreshed the page, and now its gone. How can i bring it back? – Newton fan 01 Jul 10 '18 at 12:22
  • Try this: google.com/webhp?hl=en&gl=en – Hopman Jul 10 '18 at 13:18
  • Yes, now it works fine. The appended parameters do the job – Newton fan 01 Jul 11 '18 at 8:05
  • initially, this solution looked like an ugly workaround, to have to paste this custom url everytime in the search box; but i mapped the homepage to this url, and everything is fine – Newton fan 01 Jul 11 '18 at 14:13
0

You confuse Fx language (UI) from pages language; in particular, you confuse google preferences (specific page) from general Accept-Language header value your Fx sends. I won't put click path here, as such things change over the time, so for now just look here, here or here.

  • I did this already. The language is set to ENGLISH(US), and no other languages are present – Newton fan 01 Jul 11 '18 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.