1

Let's say I have two Google accounts: perso@gmail.com and pro@gmail.com.

I am connected to Gmail on my perso account. I have added pro as an alias address to send mail as, in the Gmail settings (Settings > Accounts and Import > Send mail as).

But, when I select the pro@gmail.com address when sending a mail, some of my contacts sometimes still see the original, perso@gmail.com address. And by checking the raw message, apparently, perso@gmail.com is still used in the Sender: field; pro@gmail.com is only present in the From: field.

How to make it so that the persons I send mail to never see the address perso@gmail.com? I tried checking and unchecking "Treat as an alias" in the Gmail settings, but this did not change.

0

not possible. even if its set up like this:

it will still shows (under Show Original) which account was an initial sender; and the initial sender is also shown if it was sent from a delegate account

  • well, yes, it looks like this, and yet the Sender: field in the mail uses the wrong mail. The From: field is correct. You can check it yourself by sending a mail from your alias and then going to the "View original" option in the sent mail. – Jean-Michaël Celerier Jul 17 '18 at 22:09
  • @Jean-MichaëlCelerier you are right. I even tried to send it from my delegate account and it still shows my supreme email but now in X-Google-Sender-Delegation: ... my conclusion - it's not possible to anonymize it – user0 Jul 17 '18 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.