7

We have a G suite account where all users add to and edit one calendar. When we got a new employee, as a Super Admin, I was unable to add them to the calendar nor edit the permissions.

I went on a hunt to figure out who it belonged to as I seemingly didn't have access to it, telling me that it may be outside of our domain. Miraculously, after reactivating and logging into an old suspended account from a previous employee, I found it under "My Calendars". When I tried to go edit the permissions, I ran into the same problem, the options had no dropdown/were greyed out and they only allowed people to view events.

So I exported the calendars and transferred ownership of the calendars to my admin account, but when I logged in, the transferred calendars displayed nothing. Luckily the export worked and I was able to bring in the calendar to a newly created calendar on the Admin account, but then that only allowed me to set it to view only again for the organization, everything else was greyed out!

I was able to add each individual account with the permission to edit, so in the end it worked out, but my question is why was I not able to edit permissions as a super admin or when it was listed under my calendar in the owners account, and why did nothing transfer over?

2 Answers 2

2

I had a similar problem before. I just did some more test, and here is my conclusion:

  • "Make changes to events" is not available for "Make available for organization" (the last two options are grayed out for me also).
  • You have to explicitly invite users...
  • Or you can create a user group, add members to that user group, and then invite the user group. For example, we have a "[email protected]" user group which includes everyone. User group is also handy for sending mail to people in a group or for sharing documents with a group.
  • However, if a user group includes external users, they aren't granted access to the calendar. You have to add external users individually.
1
  • This worked, thanks! I found that changing the external settings in the google admin seems to work as well? Seems odd that that would affect people who are within the domain. Commented Jul 26, 2018 at 18:35
12

Okay, so I found how to do this.

You need to need to login to your G Suite admin account. Navigate to Apps -> G Suite -> Calendar -> Sharing Settings -> change the "External sharing options for primary calendars" to share all.

NB: You also need to do this in Apps -> G Suite -> Calendar -> General Settings, and save.

Then go back to your calendars and you will see the "make changes and manage sharing" available.

6
  • note this can take a while to propagate.
    – CAD bloke
    Commented Dec 20, 2019 at 1:07
  • 1
    I waited 18 hours and it still doesn't work. I'll try again after 24 hours Commented Apr 21, 2021 at 15:08
  • 2
    This doesn't work in Google Workspace. No idea if it was changed or anything. Commented Mar 25, 2022 at 11:13
  • Followed the above instructions - doesn't work sharing of the calendar with external people on Google Workspace.The 2 last options are grayed out for individually shared calendar.
    – Paktas
    Commented Aug 11, 2023 at 10:24
  • This worked today for me on google workspace, as in, a paid business account, and propagated instantly. The crux was that I had only updated the setting under "sharing settings" for google calendar, however that's not enough. A couple days later I saw this and also updated the identical setting under "general settings," which instantly allowed me to give others "Make changes and manage sharing" settings for company calendars, even if they're external. Absolutely no idea what's going on over at Google.
    – Caleb Jay
    Commented Sep 21, 2023 at 7:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.