1

On a Google search results page, I go to Settings -> Languages and set desired language preferences.

However, on the next day language setting reset to what seems to be regional defaults.

I'm always logged in and I'm using Google on Windows, Linux and Android devices. My browser is Chrome.

How do I persist language settings?

  • This looks like a bug that should be reported to Google by using google-feedback --> webapps.stackexchange.com/q/37061/88163 – Rubén Jul 29 '18 at 14:45
  • did you check if you dont have your search engine saved in chrome as regional one? – user0 Jul 29 '18 at 21:15
  • user0, ah, that may be the case! I've switched the Chrome search option to use google.com. Hopefully, that will do the trick. Meanwhile, can you please post your suggestion as an answer so that I can accept it? – lolmaus - Andrey Mikhaylov Jul 30 '18 at 9:47
1

The problem was caused by using a regional version of Google (google.ru) as the default search engine in Chrome.

Switching to google.com resolved the issue for me.

Kudos to user0 for the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.