0

When I view my own Facebook profile as seen by public, I noticed Message button is disabled as shown in picture below. This means public who are not my friends will not be able to message me or send me message request.

facebook

My setting page is:

facebook2

Other forums suggest there is settings page under Privacy and there is a link like "Who can send you Facebook messages?: (drop drown selection button)" But there is no such link.

I want to enable Message button on my public profile. How can I do that?

Screenshot showing privacy settings:

privacy settings

  • Second screenshot is General settings, click on privacy and show us what setting you are seeing there and what option you have selected. – serenesat Sep 18 '18 at 6:42
  • privacy settings screenshot is added to question. – user61766 Sep 19 '18 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.