15

I receive lots of emails from people with screenshots, sometimes inlined, and they usually don't bother to scale the image. That means that I have to scroll to the right to get to the "Reply button", and looks generally ugly.

Is there a settings, a Chrome plugin, or a Greasemonkey script that will cause Gmail to resize the inline image if it's too large?

  • 3
    you could start replying using shortcuts.. :) – Lipis Feb 8 '11 at 10:16
  • Yup. Enable shortcuts in your Settings and when you are inside gmail, pressing "r" will give you the reply window. – Stealth Mar 24 '11 at 18:42
6

When using Chrome, install Stylebot with this stylesheet: http://stylebot.me/styles/4169

Works for me!

4

I use Stylebot for Chrome with the following css. I catches images and those ugly copy and paste tables people paste in periodically:

body.aAU blockquote {
    max-width: 90%;
}

body.aAU blockquote img{
    max-width: 100%;
    height:auto;
}
3

Pastymage's suggested extension did not work for me, but an alternative extension worked well for me.

  • 2
    Above means which one or all of them didn't work for you? What error you get? Adding little more details would be helpful for future reader. – serenesat Sep 23 '16 at 9:42
  • Answers can also be sorted in a number of different ways, so "above" really has no meaning. Better to link to the answer to which you are referring. – ale Sep 23 '16 at 12:45
  • The "alternate extension" works great. Thanks. – Jesse Schoff May 2 '17 at 19:43
1

Other than the great shortcut suggestion, you can disable images from your e-mails (under General Mail Settings) and manually pick one by one specific senders who you trust won't mess your layout.

Also, here's a general Greasemonkey script that someone oddly said only works on Gmail.

1

That Greasemonkey script didn't work quite right for me, so I tweaked it a bit and packed it up as an extension.

0

I used Stylish for FireFox from https://userstyles.org/ In the plugin I created a new style and entered the following css-code to limit the width of images:

@-moz-document domain("mail.google.com") {

img {
   max-width: 800px;
   height: auto;
  }
}
0

This is the userstyle I wrote. It works well for me and it doesn't appear to affect any unwanted elements like other scripts I've seen do. This should only change the size of embedded images inside the body of an email.

For userstyles in Firefox use this:

@-moz-document domain("mail.google.com") {
  .h7 {
    max-width: none;
  }

  p.MsoNormal > img {
    height: auto;
    max-width: 100%;
  }
}

For userstyles in Chrome use this:

.h7 {
  max-width: none;
}

p.MsoNormal > img {
  height: auto;
  max-width: 100%;
}

Also for Chrome, the settings for "Applies to" should be:

  • URLs on the domain
  • mail.google.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.