63

In Google Docs, when I insert a table, there seem to be always a blank line above the table. See the screenshot below.

How do I prevent that?

Google Docs screenshot

4
  • Are you typing a line before you put the table in? What steps did you take in putting the table in? Unable to replicate this Feb 11 '11 at 16:30
  • 2
    Same behavior for me. At the top of the page, the extra line cannot be deleted, effectively increasing the margin.
    – kobejohn
    Oct 7 '13 at 1:21
  • 1
    @EightDaysofMalaise I believe you can replicate it by starting a new document, and inserting a table without doing anything else. There will be an empty line above the table.
    – tvk
    May 21 '14 at 18:11
  • If it's nothing professional, you could add a new page and print from page 2 on. May 15 '18 at 2:14

13 Answers 13

23

You can reduce the gap at the top of a table by placing the cursor above the table, and reducing the font size. I can't seem to reduce it below 6 points, and even this required me to type the number into the "Font size" box. However, it does at least move the table up a bit.

I had to do the same thing at the bottom of my table.

If anybody wants to log this with Google as a bug, then they could describe it as a serious bug in the conversion from docx to Google Docs format. It is serious because it does not seem to be possible to edit it out manually—at least not completely.

3
  • You can also reduce it further with line spacing. It defaults to "1.15", but you can reduce it to "Single" to make the blank lines a little shorter. May 26 '17 at 16:18
  • It now seems possible to return the font size to 1 point, which is almost perfect.
    – Michael
    Apr 16 '19 at 20:34
  • 2
    Font size to 1 and line spacing to 0.06 solves it. Oct 24 '19 at 18:48
17

This behaviour is by design and as far I am aware cannot be changed via preferences etc.

You can submit suggestions to Google Docs if you feel that you have a good case for it to be changed.

6
  • 8
    by design? but at least I should be able to remove the space after its added?
    – Jiew Meng
    Feb 8 '11 at 15:23
  • @jiewmeng - It appears so yes. I can't find any Google resource confirming it is a bug. You should be able to remove the space. I have just tested this myself. Feb 8 '11 at 15:51
  • 1
    @JiewMeng This discussion also classifies it as a design issue.
    – tvk
    May 21 '14 at 18:05
  • I think this is designed this way so that you can always add text there. I use Thunderbird mail client. If I paste a table into it at the top of an email message, there is no way to get the cursor above the table. At least Google docs doesn't have that problem. May 26 '17 at 16:20
  • 3
    It's not a good design, it'a a case of a lazy developer. You should be able to move a line outside of a table on the same line as the table to insert a line. I know, I designed and implemented edit control at a point in my career, I know the complexities associated with it. You really need a dev who is willing to go extra mile to think of all these cases. To me the idea of not being able to create a table occupying the whole page without blank line at the top is scandalous to say the least. Apr 7 '20 at 20:55
15

Right now you can fully hide the line with font size 1 and custom line spacing .06, I visually verified that saving as PDF shows no whitespace at the top.

Also, in regards to not being able to insert text before the table, it is possible to get back to the invisible line using the left arrow key while inside the table.

3
3

Here is the answer:

  1. Double Click on the space you wish to remove.
  2. Change the font to 6.
  3. Change the spacing to Single
  4. It will give you an option to "Remove space before paragraph" and "Remove space after paragraph"
5
  • 1
    when/how does it give you that option? Sep 26 '17 at 17:49
  • @kraftydevil when you are in the Google Doc, to the right of the Font
    – Holliday
    Oct 5 '17 at 11:29
  • 2
    Doesn't work for me Dec 1 '17 at 10:58
  • It's under the line spacing option
    – cjsimon
    Dec 11 '17 at 3:53
  • 2
    It is now possible to change the font to 1.
    – Konard
    May 12 '19 at 14:47
3

Google is furtive about updates, so I'm not sure when this changed: I can now enter "1", although not zero, in the Google Docs Font Size box. That pretty much takes care of this issue.

Related:

The "Page Settings - Margins" and "View - Page View" settings may be germane, such as if you're coloring your page background for onscreen display.

Finally, if you're really obsessive, open "Format - Table - Table Properties" and set Cell Padding, which defaults to .069", to zero.

(Using Chrome version "75.0.3770.100 (Official Build) (64-bit)" on MacPro w/ High Sierra 10.13.6 and Calibri font)

2

If you don't like the extra whitespace, just delete any extra carriage returns after the table of contents object.

For example, select some text within the first line after the table of contents, click Format → Line spacing and select Remove space before paragraph.

2

If your table is on the top of the page and every page contains a table you could reduce the margin of the complete document by the height of that first line.

1
  • 1
    Seems highly unlikely that "and every page contains a table". Not only would every page have to contain a table, but that table would have to be the first thing on every page.
    – zundi
    Mar 21 '18 at 20:09
2

There is only one method I found that works. It's pretty hacky, and only works for tables at the top of a page (from pages 2 and on).

First to show that it doesn't work for a table at the top of a document:

enter image description here

Notice the empty line (text added to make it clear there is an extra line there).

Next to show that it doesn't work with a page break inserted right before it:

enter image description here

And finally to show that it does work when you let the text flow to the next page:

enter image description here

So really there is a new line before that table, it just exists on the page before it, so you don't see it.

I've seen documents that had this behavior, and wanted to figure out how they worked, so I tried it out and found the above.

It's a very limited use-case, but if you really need this functionality too, then just add newlines above the table, until it's at the very top of the next page.

1

I changed the font size of the empty line above the table to 6 (as suggested above), and changed the size of the page's top margin. Both reduced the white space at the top of the page.

1
  • 3
    Note that "above" has no context in answers, since they can be sorted a number of ways, and if sorted by the default, "votes", the sort will change has answers are voted on. To refer to a different answer, it's better to link to it.
    – ale
    Oct 8 '16 at 22:33
1

I don't see a way to remove it. My workaround is to add a caption above your table, which will replace the unused whitespace.

1

It is now 2021 and I have this same issue. I can make a table full width by removing the page margins, but that gap remained at the top of the page because of an empty text line. I have managed to find a workaround.

Above the table, put your caret (the text cursor) on that line, and through the menu at the top select Format > Line spacing > Custom spacing (as shown below):

Custom line spacing menu navigation

You'll then be presented with a in-page dialog box to enter custom line spacing, it will only let you enter a number between 0.06 and 100, so enter 0.06:

Custom line spacing dialog

Your caret is now positioned above the page document. There may or may not be 1 pixel of a gap left behind between the top of the page and the table but this appears to disappear when you finish it off by setting the text size to 1.

After exporting the document to PDF and zooming in, there is no visible gap at all so I consider this a working solution.

0

With an apple keyboard...Put your curser in the first cell top left of the table. Press and hold control key. Press delete key.

With a Windows machine and standard keyboard...Put your curser on the line you want to delete and press the Delete key.

-4

It is just your cursor that is above the table. If you move it, it will not be there anymore.

2
  • 5
    But the empty line will still be there, right? Apr 10 '14 at 8:04
  • 3
    Did you actually try this? Backspace and delete won't remove it. I would downvote this answer if I could.
    – PJ Brunet
    Nov 29 '14 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.