0

When I type "product.name" or "product.id" into a cell, it's auto–formatted as a URL (different colour, underlined, hover shows it as an external link). But it's not a URL, it's plain text.

Similar text like "product.periodLength" isn't converted to a URL.

Based on:

  1. How to set a Google Docs Spreadsheet cell format to bare text?
  2. How can I stop Google Sheets formatting a Forms response as a date?

I've tried setting the formatting to plain text and using a leading single quote ('), but it doesn't stop the text being formatted as a URL.

2

I couldn't find an absolute setting to just disable this function. However, you can disable the function from continuing to create links or start creating links in a new document simply by selecting all the cells (Ctrl+A), right-click and select "Unlink" from the options menu. As soon as you do this, Google Sheets saves the change and no hyperlinks will automatically be created. Closing and re-opening does not re-enable the function either.

  • Thanks, that did the job! – RobG Nov 8 '18 at 4:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.