20

I'm trying to use the WhatsApp web interface, but since a few days ago its giving me this error:

WhatsApp works with Google Chrome 36+

To use WhatsApp, update Chrome or use Mozilla Firefox, Safari, Microsoft Edge or Opera.

enter image description here

I'm using "Chromium Version 70.0.3538.110 (Official Build) Built on Ubuntu , running on Ubuntu 18.04 (64-bit)"

Refreshing the page doesn't seem to work to fix it.

The linked duplicate did not help me, first, I expect Chromium 70 to be detected as Google Chrome 70, since it has all the required features, and I don't have any of the listed extensions installed from the second answer.

OS: Ubuntu 18.04 (64-bit)

Browser: Chromium Version 70.0.3538.110

User-agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/70.0.3538.110 Chrome/70.0.3538.110 Safari/537.36

Extensions: (everything comes from the google chrome Webstore)

h264ify: version 1_0_9
ARC cookie exchange: version 0_1_0
GitHub Repository Size: version 0_4_1
AutoReviewComments: version 1_4_3
Octotree: version 2_5_1
uBlock Origin: version 1_17_4
Stylus: version 1_5_2
Tampermonkey: version 4_7_44
Dropbox for Gmail: version 1_1_8
Chrome Connectivity Diagnostics: version 1_2_1
Chrome Remote Desktop: version 70_0_3538_21
HTTPS Everywhere: version 2018_10_31
Google Docs Offline: version 1_7
Pastebin.com: version 3_0_2
Desktop Notifications for Android: version 4_5_2
Save to Google Drive: version 2_1_1
NetBeans Connector: version 1_1_5
LastPass: Free Password Manager: version 4_19_0_5
Advanced REST client: version 10_0_12
Terms of Service; Didn’t Read: version 2_0_0
Invert Page Colors: version 0_9_3
Render Whitespace on GitHub: version 1_3_12
StackEdit: version 1_0_13, Apps Launcher: version 2_4_11
Chrome extension source viewer: version 1_6_9
Google Keep Chrome Extension: version 3_1_18495_1258
Google Hangouts: version 2018_1108_1646_1
Vue.js devtools: version 4_1_5
Google Hangouts: version 1_3_10
WebRTC Desktop Sharing: version 5_3
Don't Fuck With Paste: version 2_5
Robot Theme, inspired by Android™: version 0_2_3
Enhanced Steam: version 9_9
Simple WebSocket Client: version 0_1_3
Data Saver: version 2_0_2
f*ck overlays: version 1_1_2
  • 2
    Possible duplicate of WhatsApp prompting me to update my browser – serenesat Dec 12 '18 at 8:22
  • 1
    What is your browser's user-agent string? – MrWhite Dec 12 '18 at 19:54
  • Do you have any extensions installed? – Rubén Dec 13 '18 at 3:49
  • 1
    I've got the same problem; I'm using Chromium "Version 71.0.3578.80 (Official Build) Built on Ubuntu , running on LinuxMint 19 (64-bit)". WhatsApp web had been working fine on Chromium for months (probably years actually) and I don't have any enabled extensions. My user agent string is "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/71.0.3578.80 Chrome/71.0.3578.80 Safari/537.36". – Richard Wiseman Dec 13 '18 at 8:34
  • 1
    I have the same problem. After an initial phase of not supporting chromium the WhatsAppWebApp was working literally for years and puff, out of nowhere, it fell back to complaining about chromium not being chrome. – Hoffmann Dec 13 '18 at 8:42
7

Workaround: Change your user agent (e.g. explained here https://winaero.com/blog/change-user-agent-chrome/) to chrome and everything works fine.

I set it to Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.80 Safari/537.36

I also wrote them an email, will post updates:

Dear WhatsApp-Support Team,

for many months, probably years the web-app was not only supported for chrome but also for it's step brother chromium. Technically they are interchangeable, both support the same features and standards. But since about a week ago the app stopped working on chromium. It doesn't seem to be a problem of a missing feature as spoofing the user agent allows me to still use the app. It's just kinda hacky and I'd prefer it to work native (again).

Season's greetings

Update 17. Dec: Ping-pong with WA support

  • 1
    I've tried "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1944.0 Safari/537.36 Mozilla/5.0 (iPad; U; CPU OS 3_2 like Mac OS X; en-us) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0.4 Mobile/7B334b Safari/537.36" but still get the same message... I've also tried "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0" which is my Firefox's user agent string and that doesn't work either - even though WhatsApp still works on Firefox. – Richard Wiseman Dec 13 '18 at 8:55
  • 2
    Thanks for posting your user agent string @Hoffmann. I've set mine to the same thing but still get the unwanted message! :-( – Richard Wiseman Dec 13 '18 at 11:26
  • 2
    This has no effect with Chromium 71. – Luís de Sousa Dec 14 '18 at 7:21
  • 1
    @LuísdeSousa You may need to clear your cookies too. That did the trick for me. – Christian Brüggemann Dec 14 '18 at 10:34
  • 1
    I concur that like @LuísdeSousa it had no effect for me in Chromium 71, until I first cleared the Whatsapp Web cookie (using the icon next to the URL) and THEN changed the user agent in developer settings. Unfortunately, this has to be repeated every time you restart the browser, because the user agent settings do not persist. – JBentley Dec 20 '18 at 0:11
4

I also sent a couple of e-mails back and forth to WhatsApp support. At first they dismissed the issue I was having, also blaming it on my browser. After providing them various links to pages like these, they sent me the following earlier today:

Hi,

Thanks for your message.

Sorry for the inconvenience. We are aware of the issue and we are working on fixing it in a future update of WhatsApp. Unfortunately, we can't comment on any future release dates at this time.

Thanks for your understanding and cooperation.

Cheers, [Name redacted], WhatsApp Support Team

Let's hope for the best!

  • 1
    Great, well done. This is clearly a big problem - when I Google'd it, I found plenty of people having the same issue in the last few weeks. – JBentley Dec 19 '18 at 23:41
0

You must to set an userAgent in the call. Here you have a list of userAgents.

mainWindow.loadURL(
  "https://web.whatsapp.com/",
  {userAgent: 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36'}
);

protected by Community Jul 2 at 11:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.