0

My setup is as follows.

I have two Gmail accounts: a main Gmail account, and a secondary one that I have so I can use Google's SMTP server.

This SMTP server account is used whenever I need a server/script/IOT device/whatever to send mail to me so that I don't need to configure my main Gmail credentials (or more accurately, an app password) within the unsecured device.

My main Gmail account (say main@gmail.com) is setup to pull email from the SMTP account (say smtp@gmail.com) using the option "Check email from other accounts".

An example setup would be a cron job on Linux emailing me its run result. This would be sent to root@localhost and .forward contains main@gmail.com. The server is setup to use Gmail as an SMTP relay with credentials for smtp@gmail.com and this works great.

However, in Sent for main@gmail.com I see all the mail that is sent through smtp@gmail.com. I have Send mail as configured for this account too, however, I have unchecked the Alias option which I thought caused what I am seeing.

Is there a way to prevent smtp@gmail.com sent mail from appearing in Sent in main@gmail.com?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.