29

I'm trying to create curved arrows with a custom angle/curve. I am using the "Directional Connector" from the Shapes list. It keeps connecting to the vertices of nearby shapes such as rectangles, images, etc., but I don't want that to happen. Also, I made sure the "Snap to Point" property is unchecked for that shape. What I can do to prevent it from snapping to vertices? Perhaps I'm using the wrong shape to create custom curved arrows?

Edit: I've also tried to use the "Curve" arrow shape but it still snaps to vertices of nearby objects.

5 Answers 5

24

To prevent snapping to points/objects try to press and hold CTRL+SHIFT while you move the object/arrow.

5
  • 9
    This doesn't work for me. This does a "keep proportions" resize. Alt is the key I have to press and hold instead. Drawio v 12.4.2 on Windows.
    – alelom
    Dec 15, 2020 at 16:45
  • Same as @alelom, diagrams.net on Windows.
    – vpgcloud
    Feb 21, 2023 at 14:37
  • 2
    @user0 please reconsider updating your answer.
    – vpgcloud
    Feb 21, 2023 at 14:37
  • 1
    Both the 'Ctrl +Shift' as well as the 'Alt' is working for me. May 11, 2023 at 6:26
  • CTRL SHFT copies the arrow Mar 27 at 9:54
13

My suggestion would be to start dragging a shape/arrow and then press and hold Alt. That should "stop" the snapping regardless of the grid.

1
  • 1
    It's this, aka Option key on a Mac. May 21, 2020 at 18:57
2

I couldn't find how to prevent arrows from snapping when moving them on Draw.io. However, I did manage to increase the granularity of the grid as shown here at Diagram/Grid on the right panel, and then move the vertex of an arrow while holding SHIFT, so that it sticks to the finer sub-grid of the main grid I got. That finer sub-grid gave me enough level of freedom to position my arrow's vertex.

1
  • To be clear are you saying that in your example link where it shows Grid: 5pt you increased that value such as to 10pt? Or did you decrease it?
    – Blindspots
    Jul 24, 2023 at 16:05
1

After the last update this is only achievable by disabling the grid altogether

0

For people on MacOs Monterey (v12.3.1), try holding the shift key while moving the shapes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.