1

I'm trying to watch 2160p (4k 60fps) content on YouTube, however, I experience large amounts of dropped frames... i.e. the video freezes/stutters completely (the sound is fine).

The YouTube example I use: Costa Rica - 4k 60fps - Youtube

If I watch the video in 1440p it plays fluently without any dropped frames. However, when switching to 2160p the video freezes/stutters because of the huge amount of dropped frames (80%), see below.

Dropped frames - 28 Sec. - YouTube 4k 60fps

Hence, my internet is stable and fine (via cable) and I'm using the VP9 codec in combination with HTML5 and Mozilla Firefox/Microsoft Edge (same result). I'm not using hardware acceleration.

My PC specs.:

  • MSI H97M-G43
  • Intel Core i5-4460 Boxed
  • MSI GeForce GTX 1080 GAMING X 8G
  • Crucial Ballistix Tactical BLT2C4G3D1608ET3LX0CEU
  • Seasonic M12II Evo 620W
  • LG 27UK850-W Zilver
  • Windows 10 Education (is pro version) - Version 1803 - Build 17134.590
  • Nvidia driver - 25.21.14.1771 (NVIDIA 417.71)

Hence, in my opinion, it should be enough to watch 2160p videos on YouTube? The CPU is stressed a bit, but utilization is around 80%. GPU is barely running since 2160p content requires a lot of decoding from the CPU.

Current (after 28 sec.) - Min - Max: CPU - 28 sec. - YouTube 4k 60fps

Does somebody have a clue what is wrong/how to fix it (software setting or is it really the CPU)? Thanks for any information!

  • try chrome and toggle hardware acceleration – user0 Feb 16 at 10:05
  • 1
    This is unbelievable... I just installed Chrome, and it worked perfect! So I went back to Mozilla Firefox and enabled hardware acceleration (again) and the video is working fluently now! I already played around with the setting before my post in Mozilla Firefox, but it didn't made any difference... but after installing Chrome it works?! This can't be related... just some bad luck or stupid user use... After de-installing Chrome everything still works fine! Thanks for your quick and easy solution!! – Wildman Feb 16 at 10:18
  • Firefox 68 is now well capable of playing 60fps – Surya Jul 16 at 21:20
1

The answer which solved the OP's issue:

try chrome and toggle hardware acceleration

1

Elevating the comments on the OP into an answer:

Toggling hardware acceleration off and on again may help.

In Chrome, this setting is located in chrome://settings > Advanced (at the bottom) > "System" section > Use hardware acceleration when available.

In Firefox, the setting is located in about:preferences > "Performance" section > uncheck "use recommended performance settings" > Use hardware acceleration when available. Further, there is a helpcenter article regarding troubleshooting GPU issues: http://mzl.la/1xKsEca

Using a different browser may help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.