2

If an email message contains an email address in the body, Gmail automatically converts it into a mailto: link, which is helpful.

And many times each day I've enjoyed being able to right-click a mailto: link in an email (within Gmail) and then click "Copy email address" in the context menu.

Then I can paste that email address into a program (such as when I want to search a database).

However, within the past month or so, I've noticed that I can't right-click and click "Copy email address" without Gmail then popping open a "New Message" panel and changing my current URL to have ?compose=new at the end.

I wonder if it's related to this month's rollout of new right-click features.

How can I disable it?

I'm tried of having to click the "Discard draft" trash can button so many times throughout the day.

  • Hmm… that’s strange; I don’t see this behaviour. Could it have anything to do with the mail handlers inside your browser? (In Chrome, check under SettingsAdvancedPrivacy and securityContent SettingsHandlers.) – Alex Mar 1 at 10:50
  • @Alex, I took your advice and removed Chrome as an email handler at chrome://settings/handlers?search=handlers, but that didn't have any effect on this problem. Plus, I've always had that as a handler, so something else must have changed in recent weeks. Thanks anyway. – Ryan Mar 1 at 15:39
0

Well, this is caused by the fact that Gmail detects Chrome browser and ignores global browser setting which results in converting all email addresses by injecting mailto: address before each of them.

email@address.com is converted to mailto:email@address.com and therefore clicking on such address defaults to open compose window. Manually removing mailto: part from source code fixes the issue and further right clicking won't trigger the opening of compose window.

0

0

Therefore, a solution would be to find some Chrome extension which is able to edit source code upon website load and remove all instances of mailto:

Another solution would be not clicking on an email address you want to copy, but highlight it with a mouse cursor and hitting CTRL + C

enter image description here

If you are with administrator access, this article states that mailto: scheme can be globally blacklisted: https://www.chromium.org/administrators/url-blacklist-filter-format

In other instances (outside of gmail.com) you need to delete Gmail from handlers at chrome://settings/handlers (but as already mentioned this won't work when on Gmail in Chrome)

0

I'm not sure when it was fixed, but today is the first day that I noticed not having this problem anymore.

Apparently Google finally changed their code.

People complaining about it here seem to say that it was fixed 2019-05-04.

protected by Community Mar 1 at 22:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.