1

I selected the whole sheet and re-sized the height of all rows at once to a certain height by clicking "Resize rows 1-1000" in the context menu. Then I entered some text in a cell and the text did not fit. I formatted the cell for text wrapping, but it did not fit anyway. I expected the row to automatically grow in height as I enter more text in the cell, but it did not happen. How do I reset to the default mode so rows would grow in height to auto-fit the content?

It works on a freshly created sheet on the same document, but does not work on the problematic sheet. When I copy-paste the whole problematic sheet content onto the newly created, the problem transfers to the newly created sheet.

After I copy-paste "formulas only" from the problematic onto a newly created sheet, auto-fitting height still works on the latter sheet, but my formatting and named ranges do not transfer to the new sheet.

3

I found the answer by guessing and trying.

  1. Select the rows you want the height to reset to auto for (or select the whole sheet if needed).
  2. Double-click on the border between any two of the selected rows on the row number toolbar (the one on the right)

P.S. In order to set a minimal fixed row height and still have the height auto-adjust functionality I created a column filled with "1"s by a formula, set a large font size of the column to achieve the required minimal row height, set the font color of the column to white to make the "1"s invisible, and narrowed down the column to make it take less space.

0

Sadly, this functionality was killed and partially restored (it still defaults to minimal hight of 21 which is default row hight) by the latest update and you are nowadays left to adjust row height to auto-fit after you enter all your text or set up a new version of the sheet.

  • it works on a fresh new sheet, but does not work on mine. I checked right now. – Andrej Adamenko Mar 18 at 11:54
  • 1
    in that case, you are left with the option to manually recreate whole your old sheet in the new one – user0 Mar 18 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.