0

For some reason, most Google pages have started being displayed to me in Czech. It includes Google Translate, as well as the main search page google.com. Oddly enough Gmail is still in my native language, Danish.

My Google account language settings are set to Danish, Google chrome settings are set to Danish, with English and other languages as lower priorities (but not Czech) and my windows settings are set to Danish...but still google.com and Google Translate are in Czech. I live in the Czech Republic but for a long time, Google didn't change because of that. I am wondering if Google made some changes and that language is somehow dependent on my IP location instead of language settings?

I've tried clearing browser cache, didn't help.

4 Answers 4

1

As I'm using Chrome and are unwilling to resort to VPN or a different browser I tried searching for answers again with some better keywords and found this page https://support.google.com/websearch/answer/3333234?hl=en&ref_topic=1638123&co=GENIE.Platform%3DDesktop&oco=1

which links to the search settings page here https://www.google.com/preferences#languages which includes a section for language. Selecting english on that and clicking save appears to have done the trick. This search settings page was way too difficult to find, and google ought to concentrate the language settings to one central location rather than 3 different.

1

Try to remove any Czech traces from here:

and turn off GPS/geolocation if you are on a notebook or Windows 10

0

1

In the past the translator used the operating system’s default country/language code and so it worked fine.

In the most recent update (been this way a few years now) it regressed to getting your IP location’s language code... which is a BIG mistake because people travel all the time and/or live in foreign countries and may not necessarily know or want the local language to be their default!

So someone’s shortsighted decision at Google, has basically screwed up translate for those living or traveling outside of their mother-country. :(

Btw, it’s nothing to do with the geolocation feature in the browser... that requires permission to be accessed and you’ll never be prompted in Google translate. This is not how it's done so don't go changing any geolocation options.

Any website can get your IP and then use a lookup table to get the country.

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 2 at 0:39
0

You are correct. goofle does geolocation on your system's IP address to determine where you are located. This is their basic method of deciding what country you are in and what language to use. That's why goofle results often come up in unwanted languages when using a VPN based in another country.

Gmail should always be displayed in your preferred language because you have set a language preference for that account, and when you are logged into a gmail server that preference is known. However, this preference does not necessarily propagate out to goofle's other services due to (among other things) EU privacy regulations.

If you are using Firefox, try turning geolocation on (if it is now off) and forcibly spoofing your location to be in Denmark. This topic was covered in another thread:

https://security.stackexchange.com/questions/147166/how-can-you-fake-geolocation-in-firefox

If you are using Chrome, your geolocation can also be spoofed:

https://www.expressvpn.com/support/troubleshooting/spoof-location-google-chrome/

Whether goofle will prefer the browser's geolocation report or its own IP geolocation is not clear. goofle shuffles things every week (as evidenced by the fact that you're asking this question) and what was correct last week is not this week or next.

Good luck and let us know what develops.

Not the answer you're looking for? Browse other questions tagged or ask your own question.