1

When guests complete a contact form on our website, they send to our info@emailaddress.net at our hosting company Inmotion. These are DIVI contact forms on Wordpress. Problem is, when they are then forwarded to our work Gmail account where staff can reply to them, they all come through as the same conversation in Gmail, making it a pain in the arse for us to keep splitting. It can get confusing, and it's a needless waste of time.

Gmail I believe groups emails into conversations if the email subjects are the same. In this case, the email subject is always the same, it's the static title of the DIVI contact form. Gmail filters can help me keep messages out of the spam folder, but how can I filter all the emails we get forwarded from our website email address, into new conversations/threads on Gmail?

I don't want to use a contact plugin like Contact Form 7, or Wordpress Forms, as they don't integrate well with another plugin I'm using with the DIVI contact forms called DIVI overlays.

EDIT BELOW INCLS ADDITIONAL INFO AND SOLUTION

Apologies, I didn't emphasise that it was only the mails forwarded from the contact forms on our websites which I didn't want to appear in Gmail in the same conversation thread.

Once we have replied to each individual, then it's desirable for all future mails between us and each individual to stay in the same thread. I was aware of the method you suggested, which would eliminate conversation view for all emails.

Anyhow, if anyone else has the same issue, I found it possible to achieve what I wanted by copying the ContactForm.php file to my Divi child theme details here, and editing some of the code to change the contact form senders email address, which was always the same as it was forwarded from the server, to the email address of the sender which they'd entered into a field on the form. Details of the code changes can be found here. Works perfectly.

1
  • go to Settings
  • under General tab find Conversation View
  • turn it off
  • click on Save Changes button

    0

  • Thanks for your reply. I don't think I was very clear with my question. I have edited question to elaborate, and also include a working solution. – Matt Nov 28 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.