0

I have a bunch of saved places like this one that I can't remove them:

enter image description here

After I click on it, doesn't appear as saved (Save button doesn't have the green flag on it)

enter image description here

I've tried going to Menu -> Your places -> Saved -> Click on any of the categories (Want to go in my case) and it appears in the list:

enter image description here

but if I click on the element, is the same as if I click on the map's location.

enter image description here

Unrelated with this site, but I've tried also to remove in the android app and as soon as I click on the green flag, it appears "Can't establish the connection". Worth to mention, this is not a network issue as I can click another locations without the mentioned message.

enter image description here

I found a solution to enter Google Bookmarks, but it only appear Starred places, not Favorites or Want to go. Also worth to mention this happens only with some places, not with all of them. No idea what I'm doing different with one or another.

1

I found how to remove them, going to Menu -> Your places -> Saved -> Click on the icon of the category desired -> Edit list.
Then here you could remove the location clicking on the X button:

enter image description here

Isn't the most friendly way, but is the only one I could find.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.