1

I originally set up both English and Japanese for all Google application as my understandable languages but since it started bothering me I deleted the Japanese and keep only English. However, every time I open Google map, it's in Japanese. I change the language from the setting, but again, next time, it's in Japanese. How can I fix it?

0

You should be able to change language preference in regional settings here: https://www.google.com/preferences1 or here: https://www.google.com/preferences2

  • It works now! Thank you so much. How many language settings I need to change though... – Nao Kobayashi May 10 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.