2

I enabled MFA on my Google account because I wanted to protect it. Every time I logged-in, Google tried to get me to "Don't ask again on this device", and I un-checked the checkbox every single time (grumble).

Except once.

Now I do not get any more MFA challenges when logging-in from this computer.

How can I reset that setting so it asks me for my MFA credentials again each time I log in?

I tried on another browser and I got the challenge. Is this a browser-cookie that I can delete to re-enable it?

1 Answer 1

2

Go to myaccount.google.com/security (or security.google.com).

Click the 2-Step Verification option.

You'll probably be prompted for your password to verify it's you.

Scroll to the bottom to Devices you trust. Choose "Revoke all". (Unfortunately, you can't change them piecemeal.)

Now you'll be prompted for the "second step" wherever you're trying to sign in.

3
  • Thanks! As a bonus... do you know any way to get rid of that stupid "Don't ask again on this computer" option? Jun 19, 2019 at 22:07
  • I'm afraid not. That seems to be a permanent fixture.
    – ale
    Jun 21, 2019 at 11:55
  • There's no "Devices you trust" on the 2fa section form me, has that been removed or moved elsewhere?! Apr 30 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.