0

Display at gmail account name displayed and profile picture shown

Displays name at Gmail account name displayed

enter image description here

Name not displayed at GSuite Gmail account in top right.

I went to account to personal info and there I have the name Jaswir FeatherHatGames.

  • did you click on that "change" on that green J? – user0 Jun 23 at 20:35
0

I cannot tell you exactly what to do but I can suggest you to chek some settings in your Gmail acount, go to settings > Account and check on "send mail as" if you have your name setup with your email address.

Another option is to check myaccount.google.com and look for personal information to see if you have your name setup, since, as far as I know there is no option to disable this on the Admin Console.

last but not least check the admin.google.com > users and make sure you have name and last name assigned, however, I don't think this will be since it is a required field, otherwise I would suggest to contact G Suite Support. I hope that helps, greetings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.