0

When I am abroad, everytime I go to Gmail, it does not respect my browsers user agent, which has the Accept-Language request header set to en-US.

Since my computers language is set to English, my browser is set to English, yet Google thinks I speak the language of the place I am currently in.

How can I force Gmail to speak English?

Is this possible? Maybe using a query parameter or some other mechanism.

0

After inspecting what happens when i select the language from the dropdown on the login screen using Firefox devtools. I noticed that the "hl:en" parameter gets passed to the first request.

Then i put hl=en in the querystring for the gmail login url and bookmarked the page, that seems to bring me to the English Gmail.

This solution is sufficient for me.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.