0

I'm using Firefox on Arch Linux, and the Google results are looking weird, with some text over the title to the pages' links:

enter image description here

The offending text is a link to Google's translated version of the page.

Searching on Google for the issue, the best I could find was some former Mozilla exec stating that Google does that sometimes to make people move to Chrome:

https://www.zdnet.com/article/former-mozilla-exec-google-has-sabotaged-firefox-for-years/

Anyone else seeing this issue? I'm finding it hard to explain it in English, perhaps a better wording of the issue will find some matches.

I don't think I'm changing my default search engine to DuckDuckGo, but I'm definitely not moving to Chrome :p

  • Maybe some Firefox add-ons that comes into conflict because of some custom CSS ? More, if you can tell what's the problem you can put your custom CSS easily. (For sure Google has an history of shady business practice. Overall i prefer DeepL for traduction purpose.) – pjmg Sep 11 at 9:51
  • @pjmg, it's not an add-on thing, as I have none. Regarding the translation, I don't even want it, but Google shows it on the search results, anyway. But I'll see if there's any configurations to remove that. – caxcaxcoatl Sep 13 at 0:54
  • Maybe you need to set the same language within Firefox, Archlinux and Google. Or if you want english result to use a vpn with an US IP. Or use /ncr to stop redirect (I.E. google.it/ncr for italian version, .es/ncr for spain, .co.uk/ncr for england, etc..). Can you share the url or the lang= in the html tag in the view-source ? I'm out of ideas ! :) – pjmg Sep 13 at 6:32
  • @pjmg, thanks for your ideas, but I think you're looking at this from the wrong angle. The problem is not on language or translation; the problem looks more like some bad CSS - there is text over other text, and I cannot properly read some of the links because of that. It just happens to be a link to the translation service, but that's not the core of the problem. In any case, here's the html tag: <html itemscope="" itemtype="http://schema.org/SearchResultsPage" lang="pt-BR"> – caxcaxcoatl Sep 13 at 21:55
  • By the way, I searched for a configuration to disable the translation links, but found none on the Google configurations – caxcaxcoatl Sep 13 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.